Examples


#1

I downloaded a fresh image for the gopigo. Now I logged in with SSH and change to the dir GoPiGO.
But I can only see some examples ended with *sb.
Where are the python examples for the gopigo.

Thanks


#2

I found the examples on https://github.com/DexterInd/GoPiGo/tree/master/Software/Python/Examples
But whatever I try with some examples I get no reaction from the gopigo.
I installed the new image jessie.

Any ideas ?


#3

Now I installed Wheezy again and try to run the harware_test.py but the gopigo does not react anymore.

Any ideas ?


#4

Hi input!

I’m not in front of a Pi right now but if you were attempting to reach /home/pi/Gopigo ,that would only lead to scratch examples. You have to go to /home/pi/Desktop/GoPiGo to find all the examples and libraries.


#5

Me again,

I’m trying to troubleshoot this and I have a couple of questions, just to be sure that we’re talking about similar things.

  1. When you talk about Wheezy and Jessie, are you talking about Raspbian for Robots downloaded from sourceforge, or the standard Raspberry Pi distribution from raspberrypi.org/downloads ?

  2. Did this Gopigo ever work before?

  3. If you’re running Raspbian for Robots (Jessie), there will be on the desktop a “Test and Troubleshoot” icon. if you don’t mind, put fresh batteries in the Gopigo, flip it on its back, and run the test. Please upload the log file so we can take a look at it.

Cleo


#6

I did not use the GoPiGo for several mounths till yesterday and yes it works before.
And I download raspian for robots and I have wheezy running.
I also have fresh batteries in it. My question which test can I run on wheezy and where are the file log located.

Thanks


#7

I run the test on Wheezy with the pi B+ and only one wheel was just a second spinning.
So I tried with another pi 2B and then the test was completed.
I think my gpio pins from the pi B+ are broken.

Thanks


#8

Hey input,
Just wanted to doublecheck that the problem was on the Pi and not the GoPiGo. Did you figure out what was the problem with the Pi.

-Karan