Faulty Board


#1

Hi

I received a GoPiGo base kit for Christmas - it was purchased from a UK distributor (ModMyPi).
I have put the kit together following the instructions, including updating the software. When I powered it on for the first time and ran the test program, the Pi crashed losing network connectivity (I was conected via WiFi), and the motors continued to turn until I shutdown the robot by removing the power. At the same time I noticed a very “hot” smell coming from the GoPiGo board, and the IC’s and other components were very hot to the touch. After leaving it to cool down, I reconnected it all, and this time everything works except for one motor. It isn’t the motor as I have swapped these around, I have also tried updating the firmware/software again to no avail. I have attached the log file.

I have tried contacting the UK seller (ModMyPi) but they are currently out of the office until the new year.

I am keen to get this resolved as it was a present from my wife and I am keen to learn more about robotics and the Raspberry Pi.

Kind Regards
Chris Backhouse.


#2

Hi Chris,
Can you run avrdude -c gpio -p m328p and i2cdetect -y 1 on the terminal and paste what output you get. Can you also add a few pictures of the GoPiGo board.

-Karan


#3

Hi Karan

Thanks for getting back to me. The info you require is:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude done. Thank you.

pi@dex ~ $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – 08 – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --

Having problems uploading a photo, but will try in a different reply.

Many Thanks
Chris.


#4

Hey,
It really looks like you received a broken GoPiGo board. Thanks a lot for testing it out. I’m really sorry for the frustration.

Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65. We will have one shipped to you immediately.

Again, I’m really sorry to hear about this; we’ll make it right immediately.
-Karan