Firmware Failing to Insall


#1

Hello,

I have been trying to install firmware on the GoPiGo for the last several hours to no avail. I installed the latest image available on sourceforge through Dexter Industries and have followed all of the setup instructions. I do not, however, ever receive the version number for the firmware after running the DI Software Update or the bash scripts throughout the GoPiGo directory. I am not sure how to solve this issue as every time I run the script to check the version number I always receive the version number as 0.0

How do I fix this issue and install the firmware for the GoPiGo?

Thanks,
Kasey


#2

I have also tried the debugging techniques mentioned in the other posts and am still receiving errors.


#3

Hey Kasey,
How are you powering the and can you attach a few pictures of the how you have connected the GoPiGo to the Raspberry Pi.

I’m really sorry for the frustration. We’ll make this right asap.

-Karan


#4

Hello Karan,

First off, thank you for your prompt reply. I have tried powering it using batteries (which I’ve changed to make sure they were fully charged) as well as through the wall connector for the raspberry pi. Here are a couple of pictures of my setup.


#5

Hey,
Everything looks right to me in the pictures.

It really looks like you received a broken GoPiGo. Thanks a lot for testing it out. I’m really sorry for the frustration.

Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65. (Just mention in the mail that you have been redirected from the forums and do mention your forum username too).

We will have one shipped to you immediately.

Again, I’m really sorry to hear about this; we’ll make it right immediately.

-Karan