Firmware update not working


#1

Hello, before start, i want to excuse me for my english, i’m a french student, and for a project, I have to work with the GrovePI.

So, I try for one week to update the firmware of the GropePI.

I installed the image from this link using a PC. After this one, I followed this link at the step 4.

The software update it’s working fine. But when I try to update the firmware, I get an error from avrdude (attached file).
I tried this with 2 raspberry 1 and one raspberry 2. It’s the same.

Can someone help me with this pls?

EDIT:

Hey,

I tried other way, with the command line, i got the same problems (Look at attached files), I don’t konw how to make it work, need you :smiley:

Thanks a lot :slight_smile:


#2

It looks like the Raspberry Pi is unable to detect teh chip on the GrovePi. Can you run the troubleshooting script and upload the log on the forums by following the guide here: https://www.youtube.com/watch?v=ZMadpIEYq5o. Also, can you post a few pictures of how your whole setup looks like with the Raspberry Pi and the GrovePi. Also, when and from where did you buy the Raspberry Pi from.

-Karan


#3

Hey Karan, after a lot of research, I found that i had the old grovePI, so I connected the 2 pins together, and i could update this firmware. I riend somes sensors, and it’s look like to work :slight_smile:

Now, I will try to set our installation with the sensors.

Do you know where can I find some documentations about using the differents sensors, and how retrieve the differents values and put it in a database?

Thanks for responding :slight_smile:


#4

Great to hear that the GrovePi is working for you now. There are a lot of sensor examples which you can find here: https://github.com/DexterInd/GrovePi/tree/master/Software/Python. Once you are able to read a sensor, you can use a simple script to enter the values into a DB. You can have a look at the sqlite tutorial here :http://zetcode.com/db/sqlitepythontutorial/.

-Karan