Firmware version reads as -1


#1

So I got to step 5 of the setup process (using your GoPiGo for the first time). The custom dexter industries image has been properly installed, I set up VNC, and I’m able to ssh into the rpi without any problems.

Then I ran the firmware update script as per the instructions here: https://github.com/DexterInd/GoPiGo/tree/master/Firmware

When I tried running the basic_test_all.py script nothing was working. When I printed the firmware version, it read as -1. How do I fix this?


#2

Hi @kavsub:
It looks like the firmware is not working properly for you. Can you try updating the firmware. Open the terminal and go to the GoPiGo/Firmware folder:

cd /home/Pi/Desktop/GoPiGo/Firmware

Make the firmware update script executable:

sudo chmod +x firmware_update.sh

Run the firmware update script:

sudo ./firmware_update.sh

Check if the firmware update script reports the right firmware. Make sure that the motors are disconnected before you start.

If it still does not work for you, can you paste the output that get from running the script above and also follow this guide to generate a test log and upload it on the forums


#3

Hey @karan:

Never mind, I figured out what the issue was. The rpi just wasn’t properly connected to the GoPiGo board. Everything is working fine now.


#4

This topic was automatically closed after 12 hours. New replies are no longer allowed.