Fried ATMEGA328 chip


#1

Hey Team,

I love my ArduBerries. I had them rocking a new device I made (test tube stirring pH-growth meter for bacterial suspension). Then neither would talk to my RPi. I tried everything on the software end, tried a new out-of-the-box RPi, but no love.

I switched the Atmega328 chip from an Uno, and voila! The ArduBerry listens and hollers back. (putting the old ArduBerry chip into the Uno makes the Uno deaf & dumb).

I had the AREF hooked to the 3.3V to get my device working (needs this to read from an analog light sensor) - could startup with these two connected have fried the chip? Any other thoughts on how to avoid this?

Otherwise I had 4 small lasers (like laser pointers), 4 micro fans (0.14A, 5V) connected with pull up by code-hacked PWM (10mS off, 100mS on), and 4 Adafruit analog light sensors. No shorts, for sure.

Help! Seriously, this is for a set of experiments that would help us move forward on stopping cavities in young children, and there isn’t another tool to do this.

Peace and Thanks,
Jeremy Horst, UCSF