GoBox/GoPiGo WiFi Setup Issues


#1

Hi: I’ve been working on this for a while now and I’m officially stuck. I am on a Macbook running 10.9.5.

I have successfully made it through all the steps of the first mission but can’t get past step Q.

I initially had trouble communicating with the Pi but followed the “Assigned IP” video and connected successfully and set up the network using Ethernet.

My only issue now is that when I disconnect the Ethernet cable, I can’t ping the Pi with the “ping 169.254.217.112” command (or ping dex.local) in terminal.

When I ping the assigned IP, I get the following response:

GarysComputer-7:~ gary$ ping 169.254.217.112
PING 169.254.217.112 (169.254.217.112): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
ping: sendto: No route to host
Request timeout for icmp_seq 6
ping: sendto: Host is down
Request timeout for icmp_seq 7
^C
— 169.254.217.112 ping statistics —
9 packets transmitted, 0 packets received, 100.0% packet loss
GarysComputer-7:~ gary$

I’ve tried turning the Pi off and on.

I’ve tried to ping the Pi from a couple of different Macs.

I’ve tried removing the Wifi dongle and replacing after two minutes.

I’ve also tried installing the dongle in different USB ports on the Pi.

Any ideas where to go from here?

Thanks,

Gary


#2

Hi Gary,

When you’re connected over Ethernet, and you setup the wifi dongle, do you even acquire a wifi IP address? This typically starts with a 192.168.x.x number.

I would strongly recommend you use our tutorial for Fing to try to find the Pi on your network. Here’s a link, the tutorial is pretty quick and it’s an easy to use app: http://www.dexterindustries.com/howto/fing-tool/

John


#3

Hi John:

When I am connected via Ethernet, I can acquire the static IP address (169.254.217.112) that I assigned to the Pi. I assigned this address using the video tutorial.

I reviewed the Fing tutorial you provided, downloaded it and ran it from my iPad. The Pi does not show up on Fing - but it DOES show up on the WiFi Scanner app I have on my iMac.

WiFi Scanner shows the Pi with the IP of 10.0.1.104. It was identified as (EDUP International (HK) Co., LTD). (At least I think this is the Pi - maybe it isn’t?).

So, I went ahead and opened terminal and pinged 10.0.1.104. Here was the response.

Last login: Mon May 2 22:24:10 on ttys000
You have mail.
GaryJensensComputer-7:~ garyjensen$ ping 10.0.1.120
PING 10.0.1.120 (10.0.1.120): 56 data bytes
64 bytes from 10.0.1.120: icmp_seq=0 ttl=64 time=5.023 ms
64 bytes from 10.0.1.120: icmp_seq=1 ttl=64 time=1.889 ms
64 bytes from 10.0.1.120: icmp_seq=2 ttl=64 time=10.873 ms
64 bytes from 10.0.1.120: icmp_seq=3 ttl=64 time=5.972 ms
64 bytes from 10.0.1.120: icmp_seq=4 ttl=64 time=57.398 ms
64 bytes from 10.0.1.120: icmp_seq=5 ttl=64 time=3.093 ms
64 bytes from 10.0.1.120: icmp_seq=6 ttl=64 time=2.255 ms
64 bytes from 10.0.1.120: icmp_seq=7 ttl=64 time=16.034 ms
64 bytes from 10.0.1.120: icmp_seq=8 ttl=64 time=55.453 ms
^C
— 10.0.1.120 ping statistics —
9 packets transmitted, 9 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.889/17.554/57.398/21.215 ms
GaryJensensComputer-7:~ garyjensen$ ping dex.local
ping: cannot resolve dex.local: Unknown host
GaryJensensComputer-7:~ garyjensen$

Next, I tried to ping dex.local but that came back as unknown host.

So I’m really confused. Can you help me sort this out?

  1. Is the IP 10.0.1.120 the Pi?
  • I originally assigned a static IP address to the Pi - and this is not it.Do I need to go and re-assign the Pi a new static address of 10.0.1.120?
  1. Any idea why I can’t ping dex.local on the Pi?

  2. How should I initiate a connection with the Pi for GoBox missions?

It looks like I’m getting closer - but I think this is all starting to run together in my head.

What do you think?

Thanks!

Gary


#4

just a suggestion of something to try, if you’re on a Mac. (please note that I don’t own a Mac, so this may not work)
Open up a terminal and try
ssh pi@10.0.1.120

if you get a login prompt, enter pi as a username and robots1234 as the password (note the password will NOT show up as little stars, you will get no visual feedback)

If this IP is indeed the Pi, this should work, but I’m a bit worried that Fing doesn’t find it.

Hmm, I just noticed that you mentioned the (potential) Pi is on 10.0.1.104 but you pinged 10.0.1.120 ? Are those on different runs?

Also, if this IP is indeed the Pi, you can use it in a browser directly. Type in http://10.0.1.120 (or 104) and see what happens.


#5

Hi CleoQc: Sorry, I think I mistyped. I was working on this late last night. Well, that and I don’t know what I’m doing. This is my first time playing with robots. :slight_smile: I received your message and went back through and tried to confirm a few things:

  1. The Pi still does not show up on Fing. There is still a new, unidentified device on my WiFi Scanner with the address of 10.0.1.104. At this point, I do not think this is the Pi.

  2. I opened terminal and tried to connect using ssh@ pi10.0.1.104. The request timed out.

  3. I tried to connect via browser at http://10.0.1.104 and could not.

Do you think I should hook up the Ethernet cable and try to set up the WiFi again? Or do you think this is a hardware issue? How do you suggest I troubleshoot?

Thanks so much.

Gary


#6

Ok. Here’s what I did.

  1. I went back and removed the assigned IP from the SD card

  2. I connected the Ethernet cable and pinged dex.local. Works.

  3. Connected to VNC and set up WiFi. Shows connection and IP of 10.0.1.104

  4. Sent ping to dexterindustries.com via LXTerminal. Works. Shut down VNC.

  5. Restarted Pi. Opened Terminal. Ping to dex.local comes back as “unknown host”.

  6. Also tried to ping the Pi at 10.0.1.104 - 6 packets transmitted/0 received with repeated request timeouts.

  7. Checked Fing. Dex does not show up (no idea why). Tried another WiFi scanner - Dex shows up as 10.0.1.104.

So I’ve retraced my steps and I’m still getting stuck in the same spot. I can’t seem to connect with the Pi on WiFi.

Any ideas?

Thanks,

Gary


#7

Ok, let’s try something new
Do all the steps you just listed (great list, very clear!) up to step 4
Instead of pinging dexterindustries.com, type in
ifconfig eth0
the answer you get back should list an IP address starting with 169
then type in
ifconfig wlan0
a working setup would list an IP address here, like 192.168.x.x (where the x will be numbers between 0 and 254)

an IP address starting with 10 might be valid (I’ve never seen one assigned by a router, but I haven’t seen all routers either). IP addresses starting with 192 or 10 are known as private addresses, used internally by local networks.


#8

I found this link that explains how to get your MAC own IP address

Does your MAC start with 10, or 192?


#9

Ok.

  1. Ran ifconfig eth0 and the IP address came back as 169.254.162.41

  2. Ran ifconfig wlan0 and the IP address came back 10.0.1.104. It also shows up this way on my WiFi Scanner (but not on Fing for some reason).

  3. My Mac’s IP is 10.0.1.73 (Connected on WiFi)

  4. When I connect to the Pi using Ethernet the IP in network settings shows up as 169.254.148.174

  5. On a side note, I use an Apple Extreme Base Station router that is connected to a using Fing or WiFi Scanner, everything on my network starts with a 10 address.

  6. Also, I am on fiber internet and my home web IP starts with 70 (I don’t think this matters but I thought I’d include it.)

What do you think?

G


#10

Ok, so all this sounds pretty good. It seems the IP address starting with 10 is perfectly valid for your household. (I’m not familiar with Apple products, but 10 is a perfectly valid startvalue)

We’re getting somewhere ! Let’s try the following:

  1. with your ethernet cable plugged in, and a browser (other than Safari) on your Mac, can you reach http://169.254.162.41
  2. if #1 works, and without changing anything, can you reach http://10.0.1.104 (or whatever ifconfig wlan0 would return)
  3. if #2 works, unplug the ethernet, and try to reacah http://10.0.1.104

Good luck!
Cleo


#11

Hi Cleo:

  1. With the Ethernet cable plugged in - I was able to access http://169.254.162.41 using Firefox.

  2. With the Ethernet cable still attached, I tried to reach http://10.0.1.104 and could not connect (Came up as “Web Connection Reset” on multiple attempts).

  3. Just to be safe, I went back to step 1, logged into VNC and checked my network connection. It said I was connected at the 10.0.1.104 address.

  4. I also opened Terminal and was able to ping dex.local. I was also able to ping the address in step 1 (above) but could not ping the address in step 2 (above).

Thoughts?

G


#12

Ok I’ll be honest, at this point I’m guessing.
Your Gopigo seems properly configured, it’s the communications between the Gopigo and your computer that’s the issue.
I read up a bit about your router and I see it’s dual band. The Gopigo will be on the 2.4 band and your Mac on the 5 band by default. Are you able to force your Mac to use the 2.4 and then try the above test again?


#13

That is a really good thought, especially with the IP addresses being so wonky. Currently, I have the 2.4 band and 5 band set up as separate networks. I checked and the Mac and the GoPiGo are on the 2.4. I ran the test anyway and got the same results.

Do you think I should go back to the SD card and try to assign the IP to the GoPiGo again? I could either use the 169. address or the 10. address…I did get it to connect wirelessly once using the video tutorial that Dex posted on YouTube. But I had issues after rebooting. So I was thinking my router was assigning a different IP. But as we are running these tests, the assigned network IP for the GoPiGo seems to consistently be coming in at 10.0.1.104.

I think when I actually connected with the assigned IP, I used a 169 address. I never tried the 10. address.

What do you think?

G


#14

Just for reference, here is the forum post I followed when I was initially having issues. :slight_smile:

http://www.dexterindustries.com/topic/cannot-ping-successfully/


#15

Hi G,

Assigning a new IP address might work. You might try to mimic your wifi networks IP address; usually IP addresses are “192.168.1.x” but if you can find your IP address of your Mac on the Wifi router, you could assign a different number (unused) to the GoPiGo and give that a shot.

I still think that if you have a fixed IP addrss over ethernet, can logon and connect the GOPiGo to wifi, you should be able to see your IP address (again, probably starting with “192.168.” on the wifi control panel on the Raspberry Pi. If you ping that IP address, I suspect you would get a solid response.


#16

Hi John:

  1. I connected my GPG to Ethernet, went into my Network System Prefs and saw that when connected via Ethernet, my Mac’s IP was 169.254.148.xxx. (I’m not sure where the wifi control panel of the GPG is located…)

  2. I powered down the GPG and took out the SD Card, and plugged it into my Mac. Opened the CmdLine.txt file and copies this IP into the command (assigning a fixed IP to the GPG by increasing the last digit by one - per the tutorial). I saved and closed the file.

  3. I reinserted the SD card into the GPG that is still connected via Ethernet. I pinged dex.local successfully. However, when I tried to ping the new assigned IP for the GPG, it came back with requests for timeout/no route to host.

  4. So I disconnected Ethernet. Tried to Ping dex.local and tried to ping the assigned IP of the GPG and neither worked.

  5. At this point, I am guessing that the GPG seems to be setup. If it’s a hardware problem on the GPG, maybe it is either the USB port or the dongle (probably not likely though). It seems to be more of an issue with my Mac and my GPG finding each other via WiFi.

I should probably add that I’m really new at all of this and I’m learning as we go. But it seems like I can continually get to the step where I need to connect to the GPG via WiFi and I am just unable to do so for whatever reason.

I am going to to back to the SD card and try using the IP that my WiFi scanner shows for the GPG. It’s 10.0.1.104. I’ll try switching the commandline to that and see if it works. I know it’s a longshot but I’m running out of ideas.

What do you think?

Thanks for all the help. :slight_smile:

Gary


#17

Hi John: Per my last post, here’s where I am.

  1. I went ahead and reassigned the IP for the GPG as 10.0.1.104 (the address that shows on my Wifi Scanner). But that was a no go. The weird thing is that on the VNC’s Wifi setup, this address shows up in the connection box and it shows that I have a connection. But still, I couldn’t connect via wifi.

  2. I went back and removed the assigned address from the SD card and went through all the steps again. Still couldn’t connect via Wifi. I keep getting stuck at the exact same spot and I have no idea why. Everything else runs smoothly and then I hit a wall for some reason.

  3. I’m guessing this has to do with the way my router assigns addresses on my network. Wireless network design is not my strong suit - but the basic setup is a Cisco Fiber Internet modem that’s connected to an Airport extreme base station via ethernet. The network consists of two AEBS routers with the second used as a network extender. I have the bands broken into separate networks 5 network and a 2.4 network. Both the GPG and the Mac are on the 2.4 network. The router mode is DHCP and NAT with a range from 10.0.1.2 to 10.0.1.200.

  4. For security (in case that’s the problem), I’m using a WPA2 Personal Password.

So what do you think?

G


#18

Ok, this is interesting. We used to have a standard question about the network extender, and we stopped asking it because it was so uncommon. So this is what could be causing the problem with IP addresses. That does make the network more complicated to work with unfortunately because the mDNS service (bonjour) can be disrupted with that.

The funny thing is though that you seem to be seeing “dex.local”. In your first post, step 3: "3. I reinserted the SD card into the GPG that is still connected via Ethernet. I pinged dex.local successfully. "

So after you ping “dex.local” successfully, while connected over ethernet, you should next login to your Pi, and enter in the wifi credentials.

In this video, we’re connecting the GoPiGo to the wifi network (https://www.youtube.com/watch?v=Ha1YiB2An18&index=3&list=PLGXEJ4Ye1qCNZ9OGYTXh7o8jSgO5-NHjY) And if you look at 4:28, you’ll see where we connected to wifi. After you connect the wifi to your network, in wpa_gui, an IP address should appear. Here’s a screenshot.

After you have the wifi connected on the Pi, if you disconnect the ethernet cable and ping this IP address, what do you get? Do you have an IP number that looks like this?


#19
  1. Connected Ethernet and pinged dex.local successfully using Terminal.

  2. Logged on to GPG desktop (dex.local) using Firefox successfully.

  3. Checked WiFi settings. It shows I’m connected but not with the usual 169. IP address. (See screenshot). I only see a 169. IP address when I look in my Mac Network Settings, and only when I am connected via Ethernet. Otherwise, on my wifi - all network devices have IP addresses that start with 10. A couple of things I noticed:

  • On my screenshot is nothing in the “Last Message” section of “Current Settings” unlike your example.
  • I hit the “Connect” button to reconnect and I noticed a lot of dialogue running through in the "Status section before it finally settled in with a connection.
  1. Used LXT to successfully ping dexterindustries.com and google.com

  2. Rebooted GPG (Never used “reboot” previously - I just used “shutdown” on GPG desktop)

  3. Removed Ethernet cable. Waited for GPG to reboot.

  4. In Firefox, tried to connect to dex.local. No go.

Thanks!

G


#20

Any thoughts on what to try next? Any idea why my network doesn’t assign IPs that start with a 169. address? Do I need to reconfig my network and choose another DCHP option?

https://support.apple.com/kb/PH5140?locale=en_US

Here’s another article I found (see below). Do you think I could use bonjour? (See below)

Let me know what you think. Thanks, Gary

The 169.254.xxx.xxx IP address space is reserved for self-assigning or link-local IP addresses. They are used when your device is not connected to any network at all or a network that has no DHCP server, so that devices can assign their own IP address. When these devices use Bonjour, they can create their own DNS name resolution on the network. This is useful when you are connected to a network that is completely isolated; you will be able to network to other devices and even see their share names and Bonjour advertised services.

RFC 3927 (http://www.ietf.org/rfc/rfc3927.txt) covers the details of this IP address space. Section 1.6 covers the “Alternate Use Prohibition” of this IP space.

Note: In certain situations, a computer or wireless device may create an ad-hoc Wi-Fi network for setup or file sharing purposes. These Wi-Fi networks do not typically provide Internet connectivity. Common network names for some ad-hoc networks may include “Free Public WiFi”, “HP Setup”, or “default”.