GoPiGo 2 motor & light problem with beta


#1

Hello,

I gotten a GoPiGo 2 kit from parents for christmas but I have been having problems with getting the motors to spin and the front lights to come on.

I didn’t have Raspbians for Robots so I Installed it to a 16 gb sd micro using a mac. the installation was a success and my Raspberry Pi B+ booted just fine.I clicked on the Test and Troubleshoot app on the desktop which opened both the terminal and in the GUI window. I clicked Demo GoPiGo to spin the wheels. The terminal displayed that the wheels started to spin and stop and the lights were turning on and off in accordance but the GoPiGo was inanimate. I made sure the batteries were plugged in and the motors were connected but the wheels still did not move after the test. I decided to update the firmware using the DI Software Update app on the Desktop and I also decided to update Dexter Software but the updates did not fix anything. Made sure that the motors and everything else were unplugged from the GoPiGo before updating. I noticed I was using the Beta version of the Raspbian for Robots when I tried to login through my computer, and I haven’t updated Raspbian since I downloaded it on Dec 26, 2015. I have Raspbian version 2015.11.09 on a Raspberry Pi B+ and a GoPiGo 2. The GoPiGo power light goes on whenever there is power and the servo turns about 10° to the left each time I input power but that is all I have managed to succeed with my GoPiGo. The instructions say to visit the Troubleshooting page if the motors don’t work but there seems to be no such page in the instructions.

I have included a log of the last time I troubleshooted the GoPiGo using the Test and Troubleshoot app:


#2

Hi Infin8,
Sorry for the troubles with the GoPiGo.

The logs indicate that the firmware on the GoPiGo was somehow corrupted. Can you try running the firmware update from the instructions given here: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/5-using-your-gopigo-for-the-first-time/. After this can you run the basic_test_all example in GoPiGo/Software/Python folder, and see if it works. If it still does not work, can you run the troubleshooting script again and add the log here.

-Karan


#3

Sorry for the long wait

I tried reinstalling the OS as well as updating the firmware.
I updated and and tested it 3 times. No test worked so I went to get a log file.
I have included the 3 logs counting up in chronological order.
Thank you.


#4

Hey,
It really looks like you received a broken GoPiGo. Thanks a lot for testing it out. I’m really sorry for the frustration.

Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65. We will have one shipped to you immediately. Please attach the link to this forums post and add you username to the message too.

Again, I’m really sorry to hear about this; we’ll make it right immediately.
-Karan