GoPiGo 3 robot does not broadcast a Wifi signal

dexteros
pending
wifi

#1

My new GoPiGo 3 robot does not broadcast a Wifi signal. We are not getting a green light indicating wifi is broadcasting (no light at all). And I have the 8GB memory card that supposed to have DexterOS in it. What am I missing?


#2

Here is the content of the microSD I got with the GoPiGo Beginner Starter Kit


#3

Ok, I went ahead and re-flash the SD card despite being an original Dexter card – so I am assuming it was corrupted - I now have Wifi connections – I am yet to be able to have the browser connect – but that is a separate story :slight_smile: and a different topic


#4

Hi @dennys,

Are you able to connect to it with a smartphone or something? And with what machine are you trying to connect to it?

Thanks


#5

Once I re-flash Dexter OS on the SD card – and my point to point connection worked


#6

Hi @dennys,

So let me get this thing straight: the initial card you got didn’t work at all. Then the first time you reflashed it made the WiFi LED glow but you weren’t able to connect to it and then the 2nd time you reburned the card you were able to connect to the robot with a smartphone.

Does it now connect to it with a laptop too?

Thank you!


#7

Not quite - Let me explain:

Using the card the SD came with product KIT I could not connect – the wifi light did not turn ON and I could not see the GoPiGo3 on my list of networks.

I went ahead and downloaded Dexter OS and burned on the SD card and – I could see the network and I was able to connect via my laptop via Safari and Chrome.

On my iMac after establishing “network” connection – After entering “mygopigo.com” on browsers, it would not load the page – Again 100% fine in my MacBook AIR but not in the iMac – but that is a different issue


#8

Hi @dennys,

That’s weird and it shouldn’t be this way. Anyway, this is something worth looking into. @cleoqc take a look at this one so we can discuss it later on.

Thanks Dennis for your input.


#9

So if I understand this well, you have one computer that can connect but not the other?

The one that cannot connect, what is shown in the browser when you go to mygopigo.com ?
And this troublesome computer, does it:

  1. display that it’s connected to the GoPiGo network?
  2. when/if it connects, the green antenna turns blue? Or not?
  3. If the antenna is blue but you’re still not getting anything, can you try going to 10.10.10.10 ?

Thanks,
Cleo


#10

Going from memory since I have been occupied having fun with Raspbian OS (4Robots) :slight_smile:

While on Dexter OS and make the GOPiGO3 became available (Wifi led ON) and I could see the “GoPiGo” on the network list on both computers (MacBook Air and iMac).

Once I enter the “mygopigo.com”" on the browser – it always worked on the MacBook AIR – but never on the iMac.

I try several trouble shooting options (i.e entering IP address) but the results were the same.

I may try later playing with Dexter OS but now I am all IN with Raspbian OS (4Robots) and my PyCharm environment so is a little hard to go back :slight_smile:


#11

Thanks @dennys for your tests - hopefully, these will be of help for us. If you discover anything else that doesn’t work as intended, please post them here.

At the moment, the robots work on our iMacs, but we have no explanation why it doesn’t work on yours.

Thanks again for your feedback.