GoPiGo - Demo / Motors Not Working


#1

Our GoPiGo is failing when we get to the demo stage. Wifi setup worked fine and we updated for the Dexter Industries software and the GoPiGo software successfully. But when we try to initiate the GoPiGo demo, the UI indicates that the demo completed, but nothing actually happened. The terminal displayed that the wheels started to spin and stop and that the lights turned on and off, but the GoPiGo was completely inanimate. The batteries were providing power (power light on) and the motor wires were connected, but there was no movement.

I ran the test software and have attached the log.txt file. log.txt (6.2 KB)

Thanks in advance for your help.


#2

oy, that’s annoying!
Let’s see how we can get this gopigo to obey.
Looking at the log, (thank you for it!), it seems the gopigo isn’t recognised by the OS. The GoPiGo firmware didn’t get installed properly.
Can you confirm that you are running Raspbian For Robots?
Also I just want to be sure that we’re talking about the same things. Can you confirm you ran this program:

and did both “Update Dexter Software” and “Update Robot” ?

Cleo


#3

Thanks. Yes, We did both “Update Dexter Software” and “Update Robot”.

I think we’re running Raspbian for Robots (we bought the entire kit from
Dexter, and I believe that was pre-installed?). How do I confirm that I am
running it?


#4

Hi @natelipscomb,

Can you try running this command on the terminal of Pi. sudo bash /home/pi/GoPiGo/Setup/install.sh. Also paste the output that you see on running this command with your reply. After running this install, try running this sample program.

Please let us know if this helps,
-Shoban


#5

Hi Shoban -

When I run that command, I get this output:

bash: /home/pi/GoPiGo/Setup/install.sh: No such file or directory

Thanks,
Nate


#6

Friendly ping -

When I run the command you suggested, I get this output:

bash: /home/pi/GoPiGo/Setup/install.sh: No such file or directory


#7

My apologies, it seems Shoban missed a step . Try:
sudo bash /home/pi/Dexter/GoPiGo/Setup/install.sh