GoPiGo does not connect via Enternet or wifi

dexteros
wifi

#1

Hi - I have a GoPiGo and I am having trouble connecting to it. The problem has been on and off from the time I have purchased it. I have never been able to work on it for more than 30 mins. It will work for 15/20 mins and then I am no longer able to connect to dex.local. It is one of the reason why I am never able to complete any of the projects with my daughter.
Now I am not able to connect at all. I tried flashing the image but it still does not work.


#2

Hello @abhi.bhatta13

I’m sorry you’re having issues with the connection. For us to help out better, I’d need a couple of additional details.

  1. Do you have a GoPiGo2 or a GoPiGo3 ? (is the red board on top or on the bottom?)
  2. Are you running Raspbian for Robots?
  3. What type of computer are you trying to use to connect to it?
  4. Do you use a Wifi Dongle on the robot, and if yes, does it ever get hot?

We’ll get to the bottom of this!
Cleo


#3

Hello Cleo,

Thanks for looking into this. Here are the answers to your questions:

  1. The red board is at the bottom.
  2. Yes. This morning I flashed the image from this website - https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/
  3. I am using a Windows 10 Home, 64 bit laptop. I have tried using Chrome (primary), Firefox, & Edge to connect to dex.local
  4. Yes, I use a Wifi Dongle. I have not noticed the dongle getting hot, but the Raspberry Pi (board) feels hot and sometimes the left motor gets hot as well. At times. it also smells (like something burning) but I am not able to figure out where the smell is actually coming from.

Best
Abhi


#4

Thanks @abhi.bhatta13

A couple of more technical questions.
Does your home network have a 2.4Ghz and a 5GHz network? And can your laptop connect to the 5Ghz network? If it does, it will not be able to find the GoPiGo by name.

Could you download Angry IP Scanner from http://angryip.org/download/#windows
(if you don’t have Java installed on your laptop, you can download the legacy version. It’s good enough for what we need it for)

Does Angry IP Scanner see the GoPiGo?

Cleo


#5

@cleoqc my home network have both 2.4 Ghz and 5Ghz and my laptop supports dual band. However, most of the time my laptop seem to connect to 2.4 Ghz.
Angry IP Scanner was not able to see GoPiGo.

Thanks
Abhi


#6

Hello @abhi.bhatta13
the GoPiGo can only talk to the 2.4 Ghz network. And it’s been our experience that if your laptop switches to the 5Ghz then the connection fails. Is there a way you can force your laptop to stay on the 2.4 Ghz network?


#7

Hi @abhi.bhatta13,

My laptop has a dual band module and I run Windows 10 on it. I know for a fact you can specify the preferred mode in the properties panel of the WiFi module. Here’s a screenshot of where you should get to:

preferredband

So, if you have a Windows machine, then go ahead and try this option.

Thank you!


#8

Hi @cleoqc, @RobertLucian, I updated the preferred band of my laptop to 2.4GHz. However I am still not able to connect to dex.local or see GoPiGo in Angry IP Scanner. I have checked my laptop and it is connecting using 2.4 Ghz.


#9

Hi @abhi.bhatta13 ,

Well, maybe it’s time to try it the other way.

What IP address do you get by typing ifconfig for the WiFi module on your Raspberry Pi (you should be outputting the video to a screen directly)?
If there’s an assigned address for the respective WiFi module, then it means the router operates on different networks which aren’t interconnected (for some unexplained reason I haven’t heard so far).

Also, you’ve got to be sure you’re checking the private address space with Angry IP Scanner -> that’s 192.168.0.0-192.168.255.255.

Thank you!


#10

Hi @RobertLucian, I was not very sure what you meant by " typing ifconfig for the WiFi module on your Raspberry Pi (you should be outputting the video to a screen directly) ".

So this is what I did - Connected GoPiGo with my laptop via ethernet and my laptop connects to the network via wifi. ipconfig provides the following results:

Ethernet Adapter
Autoconfiguration IPv4 Address: 169.254.149.88
Subnet Mask: 255.255.0.0

Wireless LAN Adapter
Autoconfiguration IPv6 Address: 192.168.1.50
Subnet Mask: 255.255.255.0

I don’t seem to be connecting to the Raspberry Pi WiFi module at all. Any help will be appreciated.

Thanks
Abhi


#11
  1. When you boot up the GoPiGo, do you see any light activity on the green board? Near the power connection?

  2. Did you do ipconfig on the laptop? Windows requires ipconfig while Linux (which runs the GoPiGo) requires ifconfig

  3. The green board - the Raspberry Pi - can be connected to a screen (even your TV if you have an HDMI connection and cable). This is another good approach to see what’s going on. The connection must be made before you power the GoPiGo. You could even connect a keyboard through the USB connector.
    Are you in any position to do that?


#12

@cleoqc, Please see answers to your questions below:

  1. When I boot up, I see a red light and a flashing green light
  2. Yes, I ran the ipconfig command on my Windows 10 laptop
  3. I connected GoPiGo with my TV and also to a keyboard. It prompts me with a username and password. I tried with username: pi/password: ‘raspberry’ and username: pi/password: ‘robots1234’. Both times and it did not work. On my SD card I have the Dexter OS image 1.3.1.

#13

@abhi.bhatta13

I’m confused. You’re running DexterOS but you’re attempting to connect to dex.local?
dex.local is only available if you running Raspbian for Robots. All this time I was assuming you had Raspbian for Robots. My apologies.

With DexterOS, you have to change your wifi connection and connect to the access point that the GoPIGo provides and not your home wifi.

You can follow the DexterOS connection steps to help out.