GoPiGo Does not Stop

motors

#1

Just finished building our first GoPiGo3 [RasPi 3 B] using DexterOS [dexteros2.2.1plus.img] , and am able to connect to it via the web browser, but when I hit a direction button the motors run but will not stop or change direction. Seems it gets the first command and no others.

I have re-flashed the SD card a couple of times, rebooted, re patched the cables, etc. Any thoughts on how to move forward with this?

NOTE: I have now tried a couple of different SD cards on three different Raspberry Pis [V1/V2 & V3 Pi boards], all with the same control issue – Receives a run command [from DRIVE menu] and runs, but will accept no further commands, especially STOP.
Anyone have this experience?


#2

Hello @negativenine

Have you tried the stop at the top right corner? It’s coded differently. If it works (or not) will help in finding the cause.
Also dexterOS 2.2.2 is out, I would recommend trying it out.


#3

I have tried all the “STOP” buttons, once it gets started it does not stop. I am now running Raspbian for Robots so I can dig into this a little deeper, same issue running the GoPiGo controller panel.

I did a full upgrade through RfR, now I can start it through the demo, Eyes light and wheelslog.txt (386 Bytes)
run forward, but the demo does not do anything else. Opening the GoPiGo controller, I can stop it once, but if I start it again, it will not accept any other commands, including stop. I have a LOG now from the Test if anyone cares to view this. Hopefully this can shed some light.


#4

Hi @negativenine,

Yes, please show us everything you have there.

Again, as Cleo has pointed out, did you also give DexterOS 2.2.2 a shot?

Thank you!


#5

@negativenine
I have taken a look at the log you provided. All seems fine, firmware is updated properly. Battery voltage is a bit on the low side but should still work.

This points to the encoders not working properly. Can you do a visual check of the encoders on the motors? They are found on the back of the motors, just next to the spinning disks. There are two per motor and should almost touch the spinning disk without actually touching.

Are you able to send us photos of those encoders?

Thank you,
Cleo


#6

I have the latest-most updated version of Raspbian for Robots installed, and the same trouble there, starts on first command, but will not stop or react to any further commands. I will download the DexterOS 2.2.2 and see if this helps any.

Pictures of the build included. Thank you for the help with this.


#7

So the update to 2.2.2 [D-OS] did not change anything. I also pushed the little black transistors as close as possible [they kind of were anyway] without making a rubbing sound.

Still, starts running when using the DRIVE menu, but nothing else, no other commands or any of the stops work.

I’ve tried [3] different Raspberry Pi’s [v1,v2 and v3] different SD cards, different USB thumb drives, different OS’s [Raspbian for Robots and now 2 released of DexterOS].
Thanks again for any advise.


#8

Okay, I give up on this company… zero help, terrible support.

I am pretty savvy technically and was planning on using a few of these at our studio for the kids, but this one never worked, ZERO help -no real manuals, no way to directly contact the company, always pushed to this forum. I will actively push others away from this product moving forward. Without proper support I see no reason a school or other group would use these. If i had started this kit with a lesson due, I would have been in quite a bind.

This kit has never worked and I have swapped every part [ 3 Pi’s, several SD card’s, updated firmware/software, etc] and no genuine help from DEXTER.

Still a paper weight.

Thank you.


#9

My apologies, @negativenine!
I was certain I had offered to replace the motors but I cannot see that post. I don’t know what happened, I’m really sorry.

Can I convince you in replacing the motors? One of your encoders seems defective indeed.

We usually have a decent response rate, I’m not sure what happened here. We are indeed trying to help everyone out.
Give us a second chance?

Cleo


#10