GoPiGo Ethernet stopped working

gopigo

#1

I have 2 GoPiGo robots (GO BOX) and I have been getting them going at home for school (to show off at a tech night later this week). Initially I only put one together and was happily going through the missions. I had Wifi working and the motors and sensors were all good. I did one mission where I actually followed the instructions and did a software update before getting to work. Then I went for lunch and came back and was trying to show my daughter what I had done and it just wouldn’t connect. Later after a bit of googling I decided I must have turned of the GoPiGo without doing a proper shutdown and corrupted the SD card. So I got the .jessie image and burned that to the SD card and the lights came on and I was half way through the Wifi set up when the ethernet lights went off and it stopped connecting.
I couple more re-imaging and then the ethernet lights wouldn’t come on at all. SO I tried the SD card from the second GoPiGo which had the original image on - that worked for a bit and then stopped. So I built the second GoPiGo and that flickered to life for a bit then stopped working - I rebuilt the SD card and tried again, the ethernet lights intermittently flash on and then stopped. So now I have 2 separate GoPiGo’s 2 SD cards with .jessie image and nothing working. Please help.


#2

Hi @bridget,


When you say a Jessie image are you referring to our image, called Raspbian For Robots?
Because if you’re trying to use the Foundation’s original OS, then it’s not going to work for you.

Also, could you give us a link to the image you’ve used for both GoPiGos?


@cleoqc what do you think of this?


Thank you!


#3

I used the image found at https://sourceforge.net/projects/dexterindustriesraspbianflavor/

it is called - 2017.06.21_Dexter_Industries_jessie.img


#4

Hi @bridget,

Could you update the software of our Raspbian for Robots and the firmware for your GoPiGos?

On the Desktop, you can see an icon app called DI Software Update - press on Update Dexter Software. After the update finishes and you reboot, click again on DI Software Update, select the appropriate robot and then click on Update Robot.

We have been very active recently and there may be changes that need to be added.

Please keep us updated regarding your situation.

Thank you!


#5

Not without an Ethernet connection :grinning:


#6

Hi @bridget, a quick question: how are you powering your GoPiGo while you’re doing this? Sometimes if your batteries are weak, the first things to drop out are wifi and ethernet. If you aren’t, can you try again but with the USB power adapter connected to the Raspberry Pi on your GoPiGo2?


#7

Yes I was using the batteries - I’ll try now with the adapter - thanks


#8

now I remember why I was using the batteries - Plug is for US and I am in NZ :slight_smile: - This may take a couple of days


#9

except on closer inspection it s just a USB cable - so I plugged it in and everything is working a treat - I have just done the firmware update and have set up the Wifi - but have run out of time for any more - WARNING do not try to sort out your robot whilst making school lunches and herdring children onto the school bus - YOU WILL BE LATE FOR WORK!!!