GoPiGo Firmware and Software Updates


#1

We are releasing the v1.3 of the firmware along with some updates with the software.

The major changes are :

  • Scratch LED’s are working now
  • Install script made better

Do let us know what you think about this update and also suggest more features that we should add.

Also, we have an Instructables contest running http://www.dexterindustries.com/forum/?topic=pie-day-contest, so do post your projects there and get a chance to winning some awesome goodies.


#2

what is the best way to update the firmware to 1.3?

I have followed instructions:
cd Desktop/GoPiGo/Firmware/fw_ver_13/
sudo chmod +x firmware_update_13.sh
sudo ./firmware_update_13.sh

and

cd Desktop/GoPiGo/Software/Python/
sudo python setup.py install

and it tells me I am running v 1.3

but I am getting a error "trim_read is not defined"
when I try to use the tr command inside of basic_test_all.py


#3

How can I update to v 1.3


#4

Hey,
The easiest way to update to v1.3 would be to follow the instructions here: http://www.dexterindustries.com/GoPiGo/learning/python-programming-for-the-raspberry-pi-gopigo/add-trim-to-the-motors/ . You can leave the setting the trim part if you want.

Right now v1.3 is in beta so you would have to install it directly from it’s page. If it works well for everyone, we would make it default in a few weeks.

Do let us know how it goes.

-Karan


#5

Dear Karan,

I have not the subdirectory fw_ver_13 in
GoPiGo/Firmware

Jos


#6

I used this command:
git clone https://github.com/DexterInd/GoPiGo.git

found on:
http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/sdcard/

under “-Option 3: Modify your own image”

This got me an updated GoPiGo Folder with fw_ver_13


#7

When I run “sudo ./firmware_update_13.sh”, all I get is this “Syntax error: newline unexpected”.

Any ideas. I have followed the guide under “Add trim to the motors”.

Glen


#8

Hey Muskoka, are you pasting the line in, or typing it out? If you’re pasting it, can you try typing it? Sometimes new line errors get added, especially with windows.

If you’re typing it, can you send us a quick screenshot, or tell us if there are any more errors around the command?


#9

Hi John, here’s a screen shot.


#10

Never mind John, it was me, bad download of the script. About to try it now.

Glen


#11

Well that didn’t go so well. Now, within 5 seconds of turning it on the left motor goes full out. Was fine prior to the update.

Ideas?

Glen


#12

Hey,
Disconnect the motors before you start the update and connect them afterwards.

Let us know if this helps.

-Karan


#13

Thanks Karan, the motors were disconnected. I’m going to do a “fresh” install with your image from Feb 17(downloaded), update to fw 1.3, and see what happens.

Glen


#14

Started from scratch, re-installed everything, updated everything, installed firmware 1.3, and everything is working as it should. Led’s are controllable in Scratch, didn’t need any trim on the drive, it’s moving straight without any trim, at least up to 15’ so far.

Thanks for the updates Karan / John, working great.

Glen


#15

Fantastic and glad that it worked. Thanks so much for you patience and thanks for working with us on this!


#16

I should add, I’m also getting the error posted above by nkilbourn. If you give the tr cmd, the script quits right back to the command line, with the error he posted.

Glen


#17

Dear nkilbourn and Karan and John,

I am spending hours to get an GoPiGo update version 1.3

The latest I tried was this :

I used this command:
git clone https://github.com/DexterInd/GoPiGo.git

Reaction of Pi :

fatal : destination path GoPiGo exists and is not an empty directory

It should or must be simple to realise a firmware update,
on a not Dexter SD card with my own image !!!

Thanks in advance

Jos


#18

Jos, try changing directory into the GoPiGo directory, and running git pull.

cd ~/Desktop/GoPiGo

sudo git pull


#19

Dear John and nkilbourn,

I did all these things :
sudo git pull
I used this command:
git clone https://github.com/DexterInd/GoPiGo.git

found on:

http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/sdcard/

under “-Option 3: Modify your own image”

This got me an updated GoPiGo Folder

but not with fw_ver_13


#20

On sudo git pull I got the message :
updating b5edb37…d1e2609
error : Your local changes to the following files would be overwritten by merge :
Software/Python/basic_test_all.py
Software/Scratch/GoPiGoScratch.py
Please, commit your changes or stash them before yoy can merge.
Aborting

Is this a reason ver 13 will not install ?