GoPiGo install.sh breaks apt-get on debian jessie


#1

I ran into problems while installing ROS Indigo on the GoPiGo.
these are the steps I took and the way I solved it.

things stopped working when doing the ‘sudo apt-get update’

apparently the GoPiGo install.sh copies a python script named ‘gpg’ to /usr/bin
that’s a problem because SecureApt uses /usr/bin/gpg assuming it’s the GNU Privacy Guard

overwriting /usr/bin/gpg with the original file (from another Pi) fixed the problem.

I think the GoPiGo install.sh script should not copy to /usr/bin.


#2

Hey fandarel,
Thanks a lot for letting us know about the problem with gpg being copied to /usr/bin. We had done that earlier to give users a way to check the status of the GoPiGo directly from a command on the terminal. We have not been using it a lot and will remove that in the next update.

-Karan


#3

This is still an issue in the current release it seems.

apt-key and pgp --import are not working when trying to import a key

Im trying to install uv4l and update, following the install guide at:
http://www.linux-projects.org/uv4l/installation/

Is there any work-a-round available?


#4

Hey facilis, not sure, are you working with Raspbian for RObots? The original poster was not; can you confirm?


#5

Hi John,

Yes i am working with Raspbian for Robots version 2016.06.15 i think. When i cat /usr/bin/gpg i get

#!/bin/bash
python /home/pi/Desktop/GoPiGo/Software/Python/other_scripts/gopigo_status.py


#6

That got fixed approximately two weeks ago. The Dexter file called gpg has been renamed to gopigo and no longer interferes with Gnu Privacy Guard, but it’s impossible to remove /usr/bin/gpg as it could be the right thing.
Feel free to copy over the proper gpg from a regular Raspbian.
Future Raspbian for Robots will not have this issue.


#7

Will give that a go, thank you