GoPiGo Motors IOError: [Errno 5] Input/output error


#1

I believe that I successfully put together my GoPiGo robot. The initial test proved to be successful and all was well. I then followed the instructions to update the software. I disconnected the motors as instructed and rebooted the software. Now… I cannot get the motors to respond. The test says that it is telling the robot to move forward and backward but the wheels do not rotate in any direction. The following is a copy of the log that I received:

IOError: [Errno 5] Input/Output Error

This is highly disappointing as I haven’t even had the chance to use the product.


#2

Hi @mmcabezas1,

We will definitely help you to sort out this issue. This error usually comes when the sensors are not connected to the right pins or if there is a loose contact or when the firmware isn’t responding.

Can you double check your connections and can you post a few pictures of the robot and its connection.

I would encourage you to also try this program and see if the Leds on the GoPiGo board blink.

In addition to this test if you are using the Raspbian for Robots Image that Dexter Industries sells, then can you follow this guide, generate a test log and post it along with your reply. Logs will help us narrow down to the issue better.

-Shoban


#3

Ok… so I know that the pins and stuff aren’t loose but I photographed them for your inspection. Please see the attached photos:

Also, in all honesty I tried to follow the python instructions but did not seem to see any fruits to my labor. This could be a user error. I am by all standards a noob.

I did follow the trouble shooting instructional but it doesn’t allow a copy paste even though the options are visibly there. The best I can do is copy paste the IP address it seems http://192.168.0.14:8001/.

Of some of the items of note in the log:

wiringPi Not Found (ERR)
wiringPi Found
12C already removed from blacklist
SPI already removed from blacklist

CHECKING ENCODER TARGETING

Initial encoder read vals: -1 -1
Traceback (most recent call last):
File “/home/pi/Dexter/GoPiGo/Softward/Python/tests/enc_tgt_test.py”, line 69, in enc_stat=read_enc_status( )
File “build/bdist.linux-arm7l/egg/gopigo.py”, line 610, in read_enc_status
File “build/bdist.linux-arm7l/egg/gopigo.py”, line 601, in read_enc_status
IOError: [Errno 5] Input/output error


#4


#5


#6


#7

There was also one other error message on the log that I missed:

Checking I2C Bus O


Error: Could not open file /dev/i2c-0' or/dev/i2c/0’ : No such file or directory


#8

Hi @mmcabezas1,

Sorry for the frustration. Can you paste the entire logs here.

-Shoban


#9

I tried to but, it would not let me copy paste the log. I would copy it in
its entirety by highlighting the text in the log, then right clicking,
selecting copy, and then trying to paste it into the forum, but nothing
happened.

Michelle


#10

Hi @mmcabezas1,

Can you see an upload option in your reply pane, as shown in the image below?

Please use that option to upload your log as an image or as .txt file. If you are not able to upload using this option, let me know.

-Shoban


#11

Can you give me a brief tutorial on how to do this? I can upload from my computer but I could not figure out how to upload from the VNC. I apologize for my ignorance I just honestly tried to do that for a good hour before I gave up and started typing the code myself.

Also, I have a hunch that the downloads were the problem. Before downloading the updates, the device tested smoothly running back and forth as directed. But mid update the VNC shut down and I had to log back in.


#12

Hi @mmcabezas1,

Yes I too feel it would have been an interrupted update. Can you try updating it again or you can install the latest image directly following the instructions here.

You can learn from this tutorial as to how to transfer files from Pi to your PC.

Let us know if you need more help,
-Shoban


#13

I will try this on my lunch break. Thank you for your time. Fingers crossed that it works.

Question: When I click ok to reboot, should I wait for the VNC to restart itself or log back in? I wasn’t quite sure if it was the same thing as a computer restart.


#14

Hi @mmcabezas1,

Nice question, you will have to login back with the password, reboot doesn’t take you back to your Desktop directly.

-Shoban


#15

I started the imaging process but haven’t finished. When I re-image the sd card will I still want to update it after?


#16

So I re-imaged the SD card with the same problems. Please see the attached log. I do not understand the problem.

log.txt (6.3 KB)


#17

Hi @mmcabezas1,

From the logs it looks like your firmware isn’t responding. Can you do a firmware update to your GoPiGo, by typing the following command on your terminal/command line.

sudo bash /home/pi/Desktop/GoPiGo/Firmware/firmware_update.sh

Once you have done your firmware update, you should have all your programs working.

Please let us know if this helps,
-Shoban


#18

Thank YOu!!! The update through DI Software update wasn’t making any difference. Now I have movement. Sadly, I wont get to test it until tonight. Thank you for your patience.