GoPiGo Motors Not Responding


#1

I picked up a GoPiGo yesterday and the build went fine. I put it together with my son. I then tried to set it up but ran into a few issues. I did not get any response trying to SSH or VNC over ethernet. I then decided to just boot the GoPiGo as a desktop (I am using a RPi B+). I configured the Wi-Fi and after that I was able to SSH into the GoPiGo. I tried the basic commands using the sudo python basic_test_all.py program. It seemed to respond to most of the controls and commands although I noticed when it went forward it was fine but seemed to sputter going backwards and sometimes not at all.

I then decided to update the firmware and DI software. I did disconnect the motor before updating and the update scripts indicated the software and the firmware updates were successful. I watched the video on the troubleshooting program and decided to run that. It ran but the motor barely turned the wheel one direction and then barely the other way. The test said it finished correctly but based on the video I expected the wheels to spin much more. I also smelled an electronic burn smell. I disconnected and then was still able to successfully SSH into GoPiGo. The commands for movement resulted in no movement at all. It did not even sound like it was trying. Other SSH commands for information seem to still work (I can flash the LEDs, get the trim value, check the voltage) etc.

I have included the Log File.


#2

Hi,
Looks like the GoPiGo has a beta firmware and the encoders are also not working on your GoPiGo. Can you check if the encoders are connected properly on the GoPiGo and can you update the firmware to version 1.3.

To update to v1.3, goto Desktop/GoPiGo/Firmware folder by cd Desktop/GoPiGo/Firmware, make the update script executable sudo chmod +x firmware_update.sh and then run it sudo ./firmware_update.sh. Make sure that the motors are disconnected before you start.

Do let us know if this helps.

-Karan


#3

Karan,

I did as you asked and the firmware appeared to update correctly (this did way more than the the icon on the DI desktop). I did disconnect the wires while updating. Alas I had the same results. I could SSH in and check the voltage and trim and flash the LEDS but no movement whatsoever.

I then hooked it up as a desktop and ran the troubleshooting again. No movement just the LEDS coming on and off a couple of times. I am uploading the new log.txt file with this post.


#4

Hey kleetus3K,
Can you paste some pictures of the GoPiGo from the top and the GoPiGo upside down.

-Karan


#5

Pics as requested. I did try reversing the order of the of the wires for the motor…so B-W-B-W then W-B-W-B per the installation videos.


#6

Hey kleetus3K,
The GoPiGo looks all right in the pictures. I went back and tried using the GoPiGo with the firmware v1.3 and found that it doesn’t work with the new hardware. We have updated the firmware to v1.6 here :https://github.com/DexterInd/GoPiGo/tree/master/Firmware. You should update your local GoPiGo folder and run the firmware update script and check that you have v1.6 and then try the basic_test_all again to see if the GoPiGo works any better.

I am really sorry for the confusion earlier with regard to the older firmware.

Do let us know if this helps.

-Karan


#7

Karan,

I will try it again when I get home but from the log file attached to my first post I was originally running 1.6 firmware when I originally had the issue.


#8

I updated the firmware to 1.6 and the results are exactly the same. Motors doing nothing. I also updated the OS and DI software but it made no difference. It seems like the motors but it would be pretty rare for both motors to go. You would think one would fire. But if it is the control board the LED and other non-motor functions seem to be operating fine.


#9

Hi kleetus3K,
When did you buy your GoPiGo and did it work for you the first time or has it been showing the same problems ever since you started using it.

-Karan


#10

I bought it last Saturday, December 25th at a Microcenter that is more than 2.5 hours from my house. I happened to be in that area or Christmas. I assembled it Saturday but could not access it because your documentation said use the password raspberry. It was not until Sunday reading the forums I realized the password should be robots1234. After getting access through SSH I ran basic_test_all.py. It went forward fine but the would not go backwards, the motor would make noise like it was trying but would barely move. Turning in one place worked in one direction but not the other. Other functions like f, l, v, tr…all worked fine and continue to work fine. I checked the wheels and encoders to make sure they were spinning free and they were. The voltage was fine.

The next step I took was to use the GoPiGo as a desktop. I then updated the firmware after disconnecting the motor wires. The new firmware was 1.6. I also updated the Dexter Industries software at that time. While in the desktop I decided to run the troubleshooting GUI on the DI desktop. I had watched the troubleshooting program video so I expected the wheels to spin in each direction. Instead I smelled an electronic burning smell the wheels did not move at all during the test and only the LEDs came on and off during the test. The motors have not made a sound since even though I can still SSH into the GoPiGo and it is taking the commands. The lo file of that test is in first post above.


#11

Uh…Karan…any response?


#12

Hey kleetus3K,
Sorry for taking this long to reply back. I am not sure how but looks like you might have burnt the motor controller on the GoPiGo.
Thanks a lot for testing it out and I’m really sorry for the frustration.

Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65 and we will have one shipped a replacement GoPiGo to you immediately. Can you send us the broken GoPiGo back so that we can have look at it.

Again, I’m really sorry to hear about this; we’ll make it right immediately.

-Karan


#13

Thanks Karan. I submitted my information and sending the old one back is not an issue.

Thanks again for your help.