GoPiGo Not Booting Up (Raspbian for Robots)

Hello, I have a GoPiGo3. It is not booting up properly, even though I flashed about 3 times. Any solutions? Thanks!

P.S. The SD Card has Raspbian for Robots OS on it.

Hello @bfdifan21
Can you describe what’s happening?

Can you boot the Raspberry Pi by powering it via its USB port?


@cleoqc Alright, so when I switch on my robot, the green light keeps on blinking and never gets to a stopping point. I have connected my Pi via USB port, but the red light still keeps blinking. (I saw the ACT light on the Pi, they don’t “flick”, in other words, they are not on.) I also flashed the SD card with the Raspbian for Robots IMG file, it still doesn’t work. Any ideas? Thanks!

Thanks for the info, @bfdifan21

Let’s try this:
power the Raspberry Pi via the usb connector (you can even remove the batteries from the GoPiGo for now).
Can you put DexterOS in for now, instead of Raspbian for Robots? It will be easier to see if the Pi itself boots up.

For now I’m not concerned about the lights on the red board. I am trying to see if the Pi boots up on its own. With DexterOS, if the Pi boots, you will see its wifi hotspot from your computer.


@cleoqc Okay, so I have flashed DexterOS on my SD card, but there is no Wi-Fi hotspot, so I assume the Pi has not booted.


Are you using Etcher to flash the image?
Can you describe the red/green lights behaviour on the pi (not on the GoPiGo, if the Pi doesn’t boot, there’s no point in looking at the GoPiGo yet).

Are you using a Pi3, or a Pi3B+ ?


ETA: since you now have DexterOS, can you put in a USB drive, so we can get some logs? Maybe there will be logs…

@cleoqc Yes, I am using Etcher to flash the image.

On the Pi, the PWR light is on, but not the ACT light. I am using a Raspberry Pi 3 Model B. On the USB drive, it does not look like there are any logs for the GPG3.

P.S. - I have tried using an HDMI cable, but that does not work as well.


Is this problem by any chance related to the image of the SD card?

Either the SD card is defective (but usually Etcher catches that), or the Pi itself is defective.

Would you have access to a second Pi to verify the SD card? It doesn’t have to be in a GoPiGo, a desktop Pi would do just fine for this test.


any update on this thread? its sympton is exactly same as mine. Gopigo3 power LED keep flashing

I am having the same issue as bfdifan21, I have tried to set up 6 different raspberry Pi 3 B units sent in the GoPiGo kits I purchased for my school When I go through the initial setup for the Pi itself, NONE of the ACT lights ever come on, and none of them boot. I have looked at tutorial after tutorial, mixed and matched components between the 6 of them, and tried everything that I can think of to solve the problem. I’m wondering if the “preloaded” mini SD cards even have anything on them… Any help?


Sorry the robots are giving such a headache. Indeed if the ACT light doesn’t turn on, it would seem that the OS on the SD card got corrupted.

You can re-image the cards yourself by following the steps here and not deal with ordering delays.

If you bought the kits through our education account, you can request replacement SD cards but then there are delays (at the very least shipping delays)