GoPiGo will not respond to basic test script


#1

Hello,

I recently got my GoPiGo assembled, updated, (then, connected the motors) and attempted to run the basic test script. The terminal interface with directions appeared by none of the Cmds caused anything to occur with the robot. I went back and double checked all of the steps to no avail. Since everything appears to be fine on the surface, I ran a Test/Troubleshoot diagnostic on the robot and the output result is attached below. If you need any pictures or have any questions, let me know.

Please advise the next course of action I need to take at your earliest convenience.

Thank you,
Jeremy

log.txt (6.3 KB)


#2

Could you expand on what is going wrong wit the test script? Pictures of its output maybe? Sorry, just a little confused by your description. The log seemed to indicate that I2C wasn’t functioning properly. Are you using Raspbian for Robots? From googling the error: could not open /dev/i2c-0 I saw that it seemed like you had to enable i2c. Perhaps it just isn’t configured right.

Adafruit has a nice tutorial on configuring it.


#3

@jeremy.grace01: From the logs, it looks like the GoPiGo firmware is not working properly.

Can you do a firmware update to your GoPiGo, by typing the following command on your terminal/command line.

sudo bash /home/pi/Desktop/GoPiGo/Firmware/firmware_update.sh

Once you have done your firmware update, you should have all your programs working.

Can you try it out and let us know if this helps. If this doesn’t help, can you post the output of the firmware update and send another troubleshooting log.


Updated firmware GoPiGo not detected
#4

@karan : Thank you for the prompt response! Do I need to make sure the motors cables are disconnected from the board before executing this terminal command or does it matter? Also, given @graykevinb 's observation about the I2C, should follow the directions from Adafruit and pursue his recommendation as well? If so, do I need to perform it before or after running your command? Or should I just start with the command you advised?

I’m sorry about all of the questions. Since o don’t have a ton of experience, I just want to avoid causing a “snowball effect” at this point.

To answer @graykevinb, I am using the Raspian for Robots with the Raspberry Pi 3 that came with the GoPiGo.

Thanks again for the help!


#5

@karan ,
Firmware update worked!! :robot: :blue_car:

I had to adjust the motor cables after getting it to perform the basic Cmd tasks. I have a couple questions. I noticed that it tends to veer off to the right when moving forward, but doesn’t have any problems staying straight backward. I was on a carpet floor which maybe affected it. Do the robots have issues with carpets over smoother floors? Or is that something to be concerned about? I am getting a Line Follower soon, so perhaps it will be a non-issue.

Thank you again!


#6

Glad it is working!! I doubt it is a carpet issue. Check maybe if you got dust or something stuck in the wheel! (Hair is a big one!)