GoPiGo won't connect or drops connections


#1

I bought the GoPiGo last year at Christmas for my son. It worked great for a while, but now it will constantly drop connections. It never worked to go to Dex.local so I have resorted to tying a physical IP reservation to it from my router. When it does connect it the unit, it drops the connections all of the time. Has anyone else had these types of issues connecting? I have a windows 10 machine with IE and Chrome. I have even gone as far as resetting the software and it still won’t work. Any help would be great.


#2

Hi dnewman528,
What image are you using with the GoPiGo. Is the official Dexter Industries Raspbian for Robots image and can you check if there is a date on it. dex.local and a lot of other features were recently added (around April 2016), so you might not have them on the SD card that you are using. If you have a very old image, it might be better to install once by following the directions here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/ or you can buy a new SD card with the image preinstalled from our store.

-Karan


#3

Hi dnewman528, I’m sorry to hear about the troubles with the GoBox. I have a few thoughts below addressing each issue:

1). If you’re still having trouble connecting to your GoPiGo, I recommend trying our new software called “Cinch”. Rather than use dex.local over the wifi network, this lets you connect directly to the Raspberry Pi over wifi. It circumvents your network, which may be causing the problem. You can see more about Cinch here, and how to use it (scroll down to “Cinch”) (http://www.dexterindustries.com/raspberry-pi-robot-software/)

2). Dropped connections are most likely because of a battery issue. I would check that your AA batteries are fresh.

I hope this helps. Please let us know how it’s going. Best, John