GoPiGo won't ping


#1

Hi,

So the GoPiGo from the GoBox is built. I plug it through ethernet to my mac : nothing (not even leds).
I change the ethernet cable : nothing.
I plug the Pi to the TV (a set up I have with a pi B+ that works as a media center) = nothing on the screen.

I had prepared a SDcard with the dexter system for a future brickPi project
Still on the TV set, I change the SDcard = shows up on the screen.

I put the Pi back on the GoPiGa : lights on. Ping gives an IP adress, but a timeout (12 packets transmitted, 0 packets received, 100.0% packet loss). I turn off and start agoain : no ping anymore (cannot resolve dex.local: Unknown host).

Now … What could I do ?
Thanks for any help…
Chris


#2

Hi Chris,

I plug it through ethernet to my mac : nothing (not even leds). I change the ethernet cable : nothing. I plug the Pi to the TV (a set up I have with a pi B+ that works as a media center) = nothing on the screen.
Did you see the power led when you plugged the Pi in the mac. How were you powering the Pi and which SD card were you using.
I had prepared a SDcard with the dexter system for a future brickPi project Still on the TV set, I change the SDcard = shows up on the screen.
Did you just swap the SD card? Did anything else change when you started getting the display on the TV screen.
I put the Pi back on the GoPiGa : lights on. Ping gives an IP adress, but a timeout (12 packets transmitted, 0 packets received, 100.0% packet loss). I turn off and start agoain : no ping anymore (cannot resolve dex.local: Unknown host).
What IP address did you get when you tried pinging. Were the LED's blinking on the Ethernet port on the Pi?

-karan


#3

I plug it through ethernet to my mac : nothing (not even leds).
I change the ethernet cable : nothing.
I plug the Pi to the TV (a set up I have with a pi B+ that works as a media center) = nothing on the screen.

Did you see the power led when you plugged the Pi in the mac. How were you powering the Pi and which SD card were you using.

On the mac, yes, there are green and red solid lights on the Pi with the dexter SDcard. However the ethernet led are off. When on the mac the Pi is powered by batteries.

Still on the mac (powered by batteries) with the BrickPi SDcard I get blicking green light (that eventually disappear) and solid red. Ethernet leds are on.

Did you just swap the SD card? Did anything else change when you started getting the display on the TV screen.

Normally I turn off power before swapping the SDcards. But yes, that’s the only thing I changed. No I didn’t notice anything.

What IP address did you get when you tried pinging. Were the LED’s blinking on the Ethernet port on the Pi?

Sorry I didn’t write the IP address down (and I don’t get it anymore when I try to ping). The orange led is solid, the green one blinks.

Thank you.


#4

Hi Chris,
I just want to confirm that the DexterSD card you are talking about is the new SD card that you got along with the GoBox. What is the BrickPi SD card that you are talking about. Is it and older SD card from Dexter Industries, and if so can you tell us what is written on it.

Can you try burning a new image to the DexterSD card from the instructions given here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/ and let us know if that helps.

-Karan


#5

Hi Karan,

Sorry.

What I call the Dexter SDCard is the one I got from the GoBox. That doesn’t work at all.

What I call the BrickPi Card (wrong name I agree) is a new SDcard I bought recently (emtec, 8Gb) on which I burnt the raspbian for robots from that very page you just gave me. With that SDCard the Raspberry Pi displays the system on the TV but doesn’t ping with the mac.

Now I did burn the Dexter SDCard (sandisk) with 2015.11.09 image disk. I hooked it to the TV.
I typed ssh pi@raspberrypi.local and it answered :
ssh : could not resolve hostname raspberrypi.local name or service: not known.

Thank you.
Chris


#6

Hi Chris,
The host-name on the new image is dex.local, the username: pi and the password: robots1234. Can you try this out and let us know if this helps.

-Karan


#7

Well, thank you.

What happened is this (beware : long story)

I burnt again the SDCard (from a mac this time). On the TV I typed
ssh pi@raspberry.local.
It answered
ssh : could not resolve hostname raspberrypi.local name or service: not known.
Then I tried anyway the
sudo raspi-config
and it expanded the filesystem.
I tried to ping on the mac and I got
PING dex.local (169.254.126.33) : 56 data bytes
request timeout

Then I read your answer

I put the Pi back on the TV
I type ssh pi@dex.local. It answered
The autenticity of ‘dex.local’ (192.168.0.15)’ can’t be established.
followed by a line of hexadecimals
Are you sure you want to continue connecting (yes/no) ?
I typed yes
it answered :
Warning : permanently added ‘dex.local, 192.168.0.15’ (ECDSA) to the list of known hosts.

Then I had trouble with password (french keyboard) I had to quit the terminal. I came back to it and tried again
ssh pi@dex.local
Then I was able to type in the password
I got a long message of wornings that finished with :
xhost: unable to open display “”

I then tried to ping on the mac and I got the same IP addess and timeout.

I hope you can understand something out of all that !!!

Thank you.
Chris


#8

Hey Chris, sounds like we’re at least making some progress here.

ssh pi@dex.local Then I was able to type in the password I got a long message of wornings that finished with : xhost: unable to open display “”

I then tried to ping on the mac and I got the same IP addess and timeout.

I hope you can understand something out of all that !!!

I would try this:

Disconnect everything from your Pi, including the wifi dongle.
Power up the Pi with the wall power source.
Reconnect the Pi to your mac using the ethernet cable.
Open terminal and type “ping dex.local”

If that works, try to ssh in again. On the terminal use ssh pi@dex.local

Ignore the “xhost: unable to open display “”” warning. Do you have a command prompt?

If that works, what about typing in “dex.local” in your browser?


#9

Hi,

I try the Pi on the mac all by itself powered by the USB of the mac connected with the ethernet on the mac without wifi dongle : same message and timeout.

Now on the TV : it’s powered through the USB from the wall, the ethernet is pluged on the LAN (it’s identified on the network as Dex 192.168.0.15).
Yes, now I have a prompt command and yes dex.local in the browser displays dexter pages.

And I can access it with a web browser (192.168.0.15) from any machine on the LAN.

But it still won’t ping on the mac.

Thank you


#10

So the only problem now is when you power the Pi from the Mac, is that right?

TI is definitely NOT advised to power the Pi off any USB port on a computer. The Pi draws too much power and can damage your computer!


#11

The problem is when it’s connected to the mac however it’s powered.

I can have it connected from the wall (thank you for the advice).
And it still won’t ping when it’s by itself.

If I connect it to the GoPiGo (with the batteries freshly recharged), it doesn’t ping either with ou without the wifi dongle.

The mac runs on yosemite.
I did change the ethernet cable a couple of times.


#12

So if the problem is now connecting between the Mac and the Pi, start with the ethernet cable. If you connect your Mac and your Pi with an ethernet cable, taking the wifi dongle out of the Pi, what do you see? Do the ethernet lights (the leds on the side of the ethernet port) come on your Pi?


#13

Yes they do. An orange stable light and a green blincking one. Green gets solid after a while.


#14

Ok, that’s great. So if you turn you wifi off and go to the ethernet settings, is DHCP enabled?


#15

DHCP with a manual address.


#16

OK. That’s it. I made a new configuration with DHCP only (I’ll that change back later)

Now I’ll keep going.

Thank you very much.

Chris


#17

Good to know. It’s in our directions on how to configure for that, but silly me, I assumed that was done! I will be more careful to ask in the future.