Gopigo won't respond


#1

my gopigo won’t respond when using wifi. my computer and gopigo are on the same wifi. it works fine when connected over ethernet cable. thanks, thebaturas


#2

also I tried disconnecting the wifi and connecting the wifi again. I could not connect it again. I scanned tor networks and nothing came up. thebaturas


#3

Can you try this:

1). Connect again over ethernet.
2). While connected, check for your IP address on the wifi network. You should find this on the wifi manager program after it connects to your wifi network.
3). On your PC/Mac, instead of pinging dex.local, disconnect ethernet and then ping the IP address. Are you able to ping the IP address?

Also, just so I have a better idea of what’s going on, what computer are you using (mac or PC)?


#4

Yes, I can ping the IP address when connected through ethernet, but I can’t connect with wifi. I am on a mac. thanks, thebaturas


#5

Also I tried everything on your list. I was able to reconnect my wifi, but the gopigo still won’t respond. thank you, thebaturas


#6

Also I connected my wifi to the gopigo


#7

also I can’t ping the IP address when connected through wifi.


#8

Ok, so, just to confirm: you got the wifi ip address of your Pi while connected through ethernet. It starts with 192.x.x.x You ping -ed this over wifi and you get a positive response.

Next, you disconnected the ethernet cable between your computer and you Pi. Then, you pinged the same IP address from your Mac and there was no response. Is that right?


#9

Yes


#10

Are you sure that your Mac and your Pi are connected to the same wifi network?

If so, while your Pi is connected to the network over ethernet and wifi, can you pull up a terminal on the Pi, and run “ifconfig” Can you take a picture of this and post it?


#11

yes, I am sure that they are on the same wifi network. hope these photos help!


#12

another photo,


#13

one more,


#14

thanks, thebaturas


#15

Wait, It started working again all the sudden!
thanks for the help, thebaturas


#16

Hi thebaturas,
Glad to hear that it’s working. Did you make any changes to the image or your network settings.

-Karan