GoPiGo1 with Raspberry 1A - 'avrdude_5.10-4_armhf.deb': No such file or directory

Hi guys,

I have an original Raspberry 1A and a GoPiGo1. It worked properly couple of years ago. I tried to reinstall it: curl -kL | bash -s – --bypass-gui-installation

I got the following error message:
/home/pi/Dexter/lib/Dexter/script_tools/ line 50: pushd: /home/pi/Dexter/lib/AVRDUDE/avrdude: No such file or directory
dpkg: error: cannot access archive ‘avrdude_5.10-4_armhf.deb’: No such file or directory
chmod: cannot access ‘/usr/bin/avrdude’: No such file or directory
chmod: cannot access ‘’: No such file or directory
sudo: ./ command not found

Can you help me?


A first generation GoPiGo?  Wow!  That’s impressive! Can you send pictures? :exploding_head:

I might be wrong but I believe you will need to download an earlier version of the Raspbian for Robots O/S, (or whatever will run on a first generation robot), because (AFAIK) most of the current libraries have been updated for the GoPiGo-3 robots.

What O/S would you recommend for someone with a first generation GoPiGo?



My GoPiGo is quite old, so it is not in original state. But I have a original picture, it was taken in 2015:

BTW, I could install it manually with the current version of Raspian. The solution is: sudo pip3 install tornado sockjs sockjs.tornado adafruit-blinka python-periphery wiringpi


What operating system are you trying to upgrade?

First thought:
“It looks like fun!”

Second, more rational thought:
“Is that the Smithsonian Museum I hear calling?”

I’ve given this some serious thought over the last week, and the best advice I can give you at this point is to upgrade.

As far as I can tell, your OS choices are limited to an old, deprecated Dexter OS version and an equally old version of Raspbian for Robots.  That might be a challenge because, (as far as I can tell), later releases were upgraded to work with the GoPiGo-3 hardware.

In fact, (as you discovered), pretty much all the GPG libraries have been ported to the latest GoPiGo hardware.

I honestly have no idea what currently available software will run on a GPG-1.  The Dexter and Raspbian for Robots systems are what I would try.

You can try downloading and flashing either of these two and trying them out to see if they work.  If it doesn’t work, try finding an older version and try that.

Other than that, all the current work is being done on later versions of the Pi and GoPiGo-3

1 Like