GoPiGo3 I2C Ports not working in DexterOS

dexteros

#1

The I2C Ports are not working on a couple of GOPIGO3s in my class. I tried connecting the distance sensor, line follower, and TPH sensor with no luck. Bloxter says it is "Looking for. . . " I have no problem with the other robots.


#2

Hi @terryandunha,

Can you tell us what version of Bloxter are you running on those robots that work and those that have issues with the I2C port?

Thank you!


#3

I’m using the same version for both (are there different versions?) with the latest Dexter OS 1.3. When I connect to the robot it takes me to

mygopigo.com/Bloxter. I also tried Advanced Bloxter and it didn’t work as well.

I thought may be the red board got shorted out but the wheels, actuators and media all work.

Terry



#4

Hi @terryandunha,

We have a higher version of DexterOS (> 1.3.0) and that’s 1.3.1. I’m bringing @cleoqc into this discussion to see if this can be caused by the front-end stuff of DexterOS or if it’s the hardware the problem.

My gut tells me this revolves around the firmware of the GoPiGo3 and the hardware itself and not DexterOS itself.

Thank you!


#5

Hello @terryandunha

Can you run a test for me, please?
Go into Code in Python, double-click GoPiGo_Python_Examples, then double click Sample_Programs_GoPiGo3.
Scroll down until you find Read_Info.py and single click that one. Once it loads in the editor, click run right above the editor.
You’ll get printed info in a console at the bottom of your screen.

I’m mostly interested in the firmware version.

And here is a second test , please

If you scroll up in the list of sample programs, you will find easy_Distance_Sensor.py
What happens when you run this one (with the distance sensor connected)
(You will need to hit Ctrl-C to stop that program)

Thanks!

Cleo


#6

On the first test:

Hardware version 3.x.x

Firmware version 1.0.0

These are the same as the working robots

On the second test;

AttributeError: class DistanceSensor has no attribute ‘init

I burned the latest version of the Dexter OS onto a reformatted microSD drive and it appears to have solved the problem for at least one robot. Will get you a final verdict after I apply this fix on the other robots. I’m wondering if something happened after repeated updates of the OS from the USB drive.


#7

Hello @terryandunha

It does sound like something went wrong with the update. From the above error, the ports are fine, the issue was strictly software. I’m glad reburning a card fixed it.

Let me know the status of the second robot, please, when you get to it.

Cleo