GoPiGo3 Remote Controlled GopiGo3

gopigo3
project

#1

I am having difficulty connecting remotely to GoPiGo robot via laptop/mobile phone.

(remote_robot.py)

I have GoPiGo3 -running on Raspbain for Robots.
I followed the README that is posted on GoPiGo3 Github page.

After I do the following commands: sudo pip install -r requirements.txt , all goes well then I do: python remote_robot.py…server seems to boot up …However when I go to my web browser on my laptop in enter dex.local:5000 I get timed out error . I have tried firefox, chrome on laptop.

I used the SD card that came with my robot. However, I got a new SD card and flash > raspbain for robots…I have done update and upgrades . Aside from throwing the robot away I do not know how to proceed form here.

Can someone post troubleshooting step ideas here?


[DUPLICATE] GoPiGo remote_robot.py
#2

Hi @GoPiGo_Me,

I’ll try running that project and if something is bad I’ll fix it on the spot.

I’ll be back with an answer.

Thank you!


#3

Thank you! I appreciate you time!


#4

Hi @GoPiGo_Me,

I’ve just tried it on Raspbian For Robots and it worked perfectly for me.

May I suggest you access the page by using the IP address instead of the associated DNS record (dex.local)? Like this: http://<IP_ADDRESS>:5000. That’s because when the script launches, it binds itself to all available interfaces of the Raspberry Pi and therefore, you should be able to use the one that’s accessible in your network.
Use ipconfig to find out the Pi’s address; if you connect your Pi to your network via the WiFi, check the address associated for the wlan0 interface, otherwise if it’s done via an Ethernet cable, check the eth0.

Let me know if you get it to work.

Thank you!


#5

Yes, I tried the ip address (http://192.**..***:5000).

Any more ideas? I am starting fresh again… Like I had mentioned earlier I am following all the instruction on the README file plus reading some of these forums.

This is an important project for me because I have to been asked to bring this robot for a summer camp that serves underprivileged children. We want to inspire these children toward technology. If all goes well we then could expand and do work shops with these robots, but if I can’t get majority of these programs working then" we are dead in the water" before we begin.

I am starting again with a fresh flash of the SD card. The scrips / server seems to boot up, but connecting seems to be the problem. Also, I can connect to wifi when I use the vnc viewer. I do not know if that information helps. I will be working on this again in a couple of hours. Hopefully I will have better luck. If you have any more tips I would appreciate it.


#6

Today it works!!! I even used to first SD card. Interesting!

Thank you.


#7

I am having trouble again… now I am getting this error after running (remote_robot.py).

Here is a screen shot:
Capture


#8

This is an issue with the Pi Camera. It could be a software issue (a reboot would fix it) or a hardware issue.
That PiCamera cable is pretty sensitive, it must be connected just right. Otherwise it can move and no longer make proper contact.

Where did you get the camera from? Was it from us?


#9

No I bought camera on amazon. I had an extra, new one. Replaced it, but still got the error. I was about to change out the Pi, but decided to do the simple thing first. I switched out the SD card and rebooted again and that seem to fix the error. I was able to connect.

Again, thank you for all your feedback / suggestion. I really do appreciate it. Thank you.


#10

I got the camera to work when I changed out SD cards. However, when I try it again a few hours later I get the same error that I posted in picture above. It seems to me I get this error only when I am to get the program to work, but when I try again later it gives me the error in the picture.

I am wondering if it is the way I am exiting the program??? I don’t think it is my camera because I have replaced it and it would be unlikely that two cameras would be bad, especially purchased from different sources. Besides when I replaced it the first time I got the same error. It was not till I replaced the SD card that it was able to connect again. Have you heard of this happening before


#11

update: I can access my camera just using the pi board. However, once I connect the GoPiGo3 board I can not access my camera. So I know the camera works.


#12

When I get the above error in picture I have to re-flash the SD card. This seems to get my camera and remote_robot to work again. However, when I turn on my GoPiGo the power LED stays red. I still can access VNC. I am using the power unit that came with the GoPiGo3 and not the batteries. Rebooted several times.

Now. why the red light? How should I properly exit from the terminal when running remote_robot? CTRL C is probably not the correct way to end the program? Could this be the reason for the error.

I purchased the robot less than 30 days ago, but should I purchase a new GoPiGo board??

Thank you


#13

Hi @GoPiGo_Me,

The power LED indicates whether the motors have power or not. If it’s green then they can be actuated, otherwise it’s red.

The power LED has nothing to do with the project itself, so there’s no correlation between stopping the program and showing either state of the power LED on the GoPiGo.

When you want to exit the remote_control python script, just hit CTRL+C to exit gracefully.

Thank you!


#14

??? Yes…I did not think the LED light had anything to do with remote_control working or not working. The LED light is something new that is happening!

Issue / Question 1: I have to flash a new SD card in order to run remote_control. If I do not then I get error that I posted above. Why?

Issue 2 / Question 2 : Now my GoPiGo3 LED is solid red. Has been green and working fine. What could be wrong?


#15

With the information that you just provided. I attached the battery pack and solved the light issue. However, I do not know why the power cord that came with the robot is not providing power to motor. Not a big deal at the moment. So that solves question two. Now we just have question 1 left.

Another quick question. Can you still use the playstation3 dualshock remotes? Some forums off other sites says that you can’t on the new GoPiGo3.


#16

Hitting CTRL + C will make your program exit gracefully and if in some odd way it doesn’t, just kill the process by using the PID number - that will surely stop everything. You can see what’s the PID number by issuing ps aux | grep python command.

Try out a more recent version of Raspbian (or do an apt-get upgrade && apt-get dist-upgrade) if there’s one and then run the program again. Maybe there’s something within the camera’s firmware that has to be updated - I got into a similar problem months ago and an update did the job.

What OS are you currently using?

The motors have been designed to only run from a battery pack. Not enough power for the motors can be supplied through the USB cable, so another power source has to be used.

The last time I tried pairing a PlayStation3 DualShock controller with the Pi, it failed miserably. It looks like there’s no 3rd party support for the controller on the Pi. More precisely, it gets stuck in the Bluetooth pairing process. That was almost a year ago and I don’t think the situation has changed for the better.

Thank you!


#17

Thank you!

That would explain why the playstation3 controller did not work!! I just bought the GoPiGo3 so I should be running the most current raspbian. The other SD cards that I have used I downloaded from sourceforge, most current raspbian for robots.

I have not tried the apt-get dist-upgrade, but have done the apt-get update and upgrade.

Again thank you!


#18

This is probably a moot point, but the card that came with the robot I also used to download the raspbian for robots.

I will do the following suggestion later this afternoon. Thank you for all the support and help that you have provided. I do appreciate it!