GoPiGo3 WiFi Seems OK but light is out

Not always, but intermittent (on 2 bots). Sometimes I have to reboot both the bot and the browser. No biggie, but I will have 25 teams of 6th graders starting next week. They’ve built 3 games in Scratch last Spring, so they are familiar with the block coding. Just would like to understand what’s going on. They’ll be using Chromebooks so they are very familiar with re-booting a web page.

I see lots of posts where the green light is on but wifi not detected. Here it is the opposite.

One more sometimes the green/blue comes back.

Seems like the DI folks are busy these days.

Did you get an answer to your question?

On a system with the light off, when you run:

systemctl | grep antenna

Do you see:

 antenna_wifi.service     loaded activating auto-restart Antenna Wifi Indicator 

I actually turn the WiFi LED off to save a few milliamps:

# stop GoPiGo3 antenna_wifi.service
sudo systemctl stop antenna_wifi
# turn off wifi_led
python -c "import gopigo3;GPG=gopigo3.GoPiGo3();GPG.set_led(GPG.LED_WIFI,0,0,0)"

and to turn it on:

# start GoPiGo3 antenna_wifi.service
sudo systemctl start antenna_wifi

This AM I had one of my student’s GoPiGo3 light go blue and then tun off, but the bot still responded to the paired computer’s commands. Has happened before – with no operational loss that I could see. Running DexterOS 2.4.4


@cleoqc, does C need to put in a zendesk ticket or email?

Is this a known, or fixed issue?


It is a known issue that we’re still puzzled about.

1 Like


I hope you can help me.

I have a Gopigo on a rasperryPi3 bought last year.

I took the unwise move to upgrade the OS for V2… and followed the procedure (download, put on a usd key, close gopigo, put the key, open gopigo, see the 2 red blinkers blinking, wait till the light shines). All went well but now, I still get the dexter wifi sign on my pc (though the blue light does not show up anymore on the gopigo). When I enter (, my pc tells me it cannot connect. What a bad move. I went worse from expecting better. Can you help me with this? Doing the procedure again did not help. It looks like the gopigo did not download it again. I tried advised by @cyclicalobsessive (thanks). Nothing. I wondered whether I was not under V1 and tried the VA upgrade. No move. I am stuck

I hope you can help me with this.

Answered via Customer support.