Gopigo3 wifi was initially working, now is not

I recently purchased a gopigo3. When I first assembled it and powered it up, everything was fine. I was able to program the robot with bloxter in mygopigo.com.
Now a few days later I powered it up again. The red raspberry pi led is on and the green gopigo3 power led is on.
The wifi led never comes on. I can see and connect to the GoPiGo wifi router and open mygopigo.com, but I am unable to do much because it tells me that I am not connected to the device.
So the wifi connection was completely working initially, but now is apparently only partially working.
What can I do to resolve this?

Probably it is not entirely accurate to say that wifi is not working since I can connect to that and load the mygopigo.com page. But the wifi led does not come on and the browser says I am not connected to the device.
I tried a wired ethernet connection but that gives me a self-assigned ip address and the command to ping dex.local fails.
Am I correct to imagine that the dexter os is listening on some port for a socket connection that would be used for commands to the device and the browser is trying but failing to open a socket on that port? Maybe that is what is not working.
In between the time that it was working and it stopped working I installed the servo and the distance sensor but I disconnected those peripherals just in case.

Hi @kl1
This is an issue that has been haunting us for a while but of course we can’t reproduce it. Yet we’ve seen others with a similar issue.
Can you run a DexterOS_update? In most cases, this fixes the issue, even if the version doesn’t change.

Instructions are here:
https://www.dexterindustries.com/dexteros/update-dexteros/

Cleo

Hi Cleo thanks so much for your help. The update did the trick. Should I now delete that zip file from the usb drive so that it doesn’t run again?

ping dex.local does not succeed. Should it?

Now I can explore the python environment and I do have some newbie questions if I may.

I can see that python 3.6.6 interpreter is installed as part of Dexter OS and libraries are in /opt/. So that is where program execution occurs, on the raspberry pi.

Now I wonder, is JupyterLab the only way to program gopigo3? What about the code on github.com/DexterInd/gopigo3/ ? Upload to JupyterLab or is there another way?

Should I expect that in JupyterLab when I choose File > New > Notebook or File > New > Text File or in Launcher I click on Text Editor in all cases I get error – 403 forbidden?
I’m not really wanting to code interactively. So I’m trying to understand how to write and run scripts and I thought that would be with the text editor.

The zip file gets deleted automatically if the update went fine.

No. Dex.local is not recognised on DexterOS, but gopigo.local or gopigo.com is. Even more than that, but any domain is accepted (even unqualified domains) except any domains that have .local as a pseudo-TLD.

No. It should work though. Still, I saw this happen from time to time and a reboot seems to do the fix - that’s a bug in JupyterLab. Please try again and see if it works. When you create a new file, you should also rename its extension to py so that you can benefit from syntax highlighting.

Thank you!

Thanks Robert. I rebooted a couple of times and even did the os update again but I still get the 403 forbidden error. I also find that while I can load the mygopigo.com page I cannot load the gogpigo.com/python page when I have the servo and distance sensor connected. I must disconnect those peripherals. Lastly, I have never been able to get the gopigo3 to shut down without pulling all the power.
Thanks for all your help.

On that last bit – not shutting down – it does shut down if I do not have the power adapter connected.

The 403 error also happens if you’re in a read-only folder. Make sure you are in the home folder first, or any other folder that you create under that.

Huh? Those are totally unrelated from a code point of view. I understand this is what you’re getting. I’m just flabbergasted and at a complete loss at seeing the relationship between the two…

Cleo
Huh? th

With regard to the 403 error – as a total newbie with JupyterLab, I don’t know what it means to choose a folder in there. I have not created any folders or saved any files. I just open JupyterLab and try to create a new text file and I get the 403 error.

Hi Cleo sorry for the confusion. The two problems are not related and I should have been more clear about that. Furthermore, I am no longer able to reproduce the problem of opening the gopigo.com/python page (JupyterLab) when I have the servo and distance sensor connected. I have them both connected now and I don’t see the problem I saw earlier.

I suppose the right thing to do would have been to open a new topic for the 403 error. Also, the question I had about how to run the code from github.com. Do you upload that code to JupyterLab or is there another option? Thanks again.

The 403 error seems to be related to Firefox and may be avoided by using Chrome.

Using Chrome instead of Firefox made everything better with regard to the 403 error. I see lots more files and folders in Jupyter than I did with Firefox. What’s more, now if I use Firefox I see all these other files and folders and the “home” button icon which I don’t know if I noticed before. Furthermore, I do not see the same two example files that I saw initially. So it could be some kind of “cache” issue that other posters have suggested and now I have exited that troublesome condition. I don’t know if the problem was with the browser or with what was initially served.

2 Likes

Good workaround! Nice to know. We’ll add it to our list of tricks for sure.
Personnally I use Firefox and don’t have this issue so I do suspect it’s a cache issue in your setup.

Kudos for sticking through it and solving the issue.

Cleo

I keep the cache disabled on my Firefox and I’m thinking it’s a Jupyter issue on the server side that affects FF differently than Chrome for some reason. Perhaps Jupyter launches “in” some read-only folder rather than the home or default folder. The two files I originally saw had names starting with an underscore. Once the problem is cleared Firefox is fine.

1 Like