Grove 1.12" OLED (96x96) showing scrambled display

grovepi
i2c
oled

#1

The OLED is showing a scrambled display when running the grove_i2C-oled_96x96_hello_world.py script. The attached photo shows the output. Tested two different OLEDs which are giving the same results. Have tested with the latest Raspian for Robots.

Any ideas how to fix?

Thanks,

Sami


#2

Hi @s.maam,

Give us a day for testing this Grove OLED Display and then we’ll reply back on this post.

Thank you!


#3

@s.maam what else do you have on the GrovePi+? Do you have anything else attached to the I2C lines?


#4

Yes have tested with no other i2c sensors attached.

First screenshot shows response when using the grove_oled/grove_i2c_oled_96x96_hello_world.py script. There is a line of jibberish on the screen.

If we run the grove_128_64_oled_test.py we do get hello world printed (screenshot attached), thoughh it only uses half the screen, and that library is for a 128x64 pix screen, whereas ours is a 96x96 screen.

Thanks,

Sami


#5

Hey @s.maam, just installed GrovePi on Stretch and ran it with a v2.1 OLED Display and got a really good result. This is on Stretch, I’ll burn a copy of Raspbian for Robots again just to make sure!


#6

Just a quick update: I ran this with the latest Raspbian for Robots 2017.06.21_Dexter_Industries_jessie and had no problems, I had the same result.

Couple of things to check:

  • Run a GrovePi Firmware Update.
  • What version of Raspbian for Robots are you running?

#7

Hello,

Thanks for checking.

Yes have been using the same Raspian for Robots. Just noticed though that our OLED version is v2.2 (photo below). It seems to be a newer version so perhaps that is the problem?

Thanks,

Sami


#8

Boy that’s weird. Guess we now have to figure out the difference between 2.1 and 2.2; this may be a case for talking with Seeed about it. I wonder if they changed the driver on the new subversion; that would be a really unlikely thing to do.

BRB!


#9

Just opened up a question with Seeed about this here.


[SOLVED] Any examples for Grove - OLED Display 0.96 inch
#10

Did you resolve this issue? I am having the same issue. The scrambled screen looks the same as yours with the solid black bar through the middle. I am also using version 2.2 of the display and was testing the hello world sample via Grove api and GoPiGo board?


#11

We have not received an answer back from Seeed about their hardware yet. You may get faster support by reaching out to them directly. As of Dec 11, 2017, we still don’t have an answer.


#12

Is there already a solution for this issue?

Tnx!


#13

Hi @rutger,

Unfortunately, we are not that in touch with the development of Seeed products and hence this OLED screen. It’s an I2C device device, so it bypasses the GrovePi completely and this means there isn’t much that we can do.

We haven’t heard anything from them or from another user of any bug fix for it. I see Seeed didn’t come back with an answer on John’s post on their forums.

Thank you!