Grove Pi + Dead on arrival ? [SOLVED]


#1

Help !!

I think the GrovePi+ board I received from Amazon is dead.
Using the dex image, on two different Model B pi’s with same failures.

i2cdetect does not see it, full details in attachment


#2

Hi,
Can you post a picture of the GrovePi+ board connected to the Pi and one with it zoomed in on the headers. Can you also run avrdude -c gpio -p m328p and post the output here.

-Karan


#3

Hi Karan,

Thanks for the help.

BTW, the LED on the grove Pi+ has been illuminated properly, so I don’t think it’s a power issue.
I am a very experienced PI user, all usb devices are on a powered hub, and I use a 2A capable PSU for the Pi itself.

pi@dex ~/Desktop/GrovePi/Troubleshooting $ sudo avrdude -c gpio -p m328p
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
avrdude done. Thank you.

Note: I adhere to static safe practices, and the pins are all aligned and not damaged.


#4

I have downloaded, burned and loaded the dexter version of image to a microSD card and tried it out on a Model B+, and it fails the same way. The kit I purchased was this one.

http://www.amazon.com/gp/product/B00TXTZ5SQ?keywords=grovepi&qid=1450718784&ref_=sr_1_cc_1&s=aps&sr=1-1-catcorr

Perhaps I have missed something critical or I am doing something stupid.

:frowning:


#5

Hey,
It really looks like you received a broken GrovePi+. Thanks a lot for testing it out. I’m really sorry for the frustration.

Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65 with you forum username and shipping address. We will have one shipped to you immediately.

Again, I’m really sorry to hear about this; we’ll make it right immediately.

-Karan


#6

ok, thanks Karan for sorting it out. I have completed the form as you suggested.


#7

Hey all, just as a quick followup: I got this board and just tested it. It was indeed a manufacturing defect. Easy to repair with a soldering iron.