Grove Pizeo Vibration Sensor giving high reading on Grove Pi


#1

Hello,

Am getting strange results with the Grove Piezo Sensor. It is giving high readings all the time (value = 1024), using the grove_pizeo_vibration_sensor.py script . Tried with 2 different sensors. Still gives high readings. It randomly outputs 0 readings every now and then.

Have tried shaking and moving the sensor, and the reading generally stay at 1024 the whole time, even when I stop moving the sensor.

Any ideas why?

Thanks,

Sami


#2

Have retested with Raspian for Robots. Was previously just using normal Raspian and then updating the GrovePi software via the setup software guide and then updating the firmware.

The sensor still dosent work very cleanly or robustly though. The sample rate on the grovepi example script for the piezo sensor was at 0.5 seconds which was a bit too slow to pick up any vibrations. I tried at a faster sample rate of 0.1 seconds, and it picked up vibrations better, though the results are not always very stable and a bit noisy


#3

Hi @s.maam again,

I’m (again) glad to hear an update was the thing it needed to be done.

Could you do make some graphs with the values you’re getting from the piezo sensor?

  • On the Y axis there should be the values you’re getting with the Grove Piezo Sensor.

  • On the X axis there should be the time.

Also, please specify what’s the acquisition rate of the samples in each graph.

Edit

Have you adjusted the sensitivity of the sensor with a screwdriver?

Thank you!


#4

Hey Robert,

I am facing a similar problrm and yes i tried increasing the sensitivity with screwdriver but the problem still remains.