Grove Relay clicks and LED turns on but nothing else

Hey guys,

I am trying to make a water pump pump water through my Raspberry Pi. I have connected the relay successfully but when I wire it to anything it clicks and turns on and off, like my script says it should, but nothing is happening to the water pump. I’ve tried it with other actuators like a motor and it also doesn’t work. I’ve tried to connect it with an external power supply too with no success. The relay is 5V and won’t work powered through a power supply nor the RPi. The water pump is 5v. What could it be? I’d be very grateful of your help. If you need any pictures/details please ask. Thanks.


We can’t help without more details.

If the relay clicks when you turn it on or off according to the script, but nothing you connect to it works try this:

Take the two wires that connect the relay to the water pump and short them together. The water pump should start working.

If the water pump starts working, then the relay is defective.

If the water pump does NOT start working, then there is a problem with the water pump, the power supply to the water pump, or the wiring.


  • Do NOT short the wires from the Raspberry Pi to the relay.
  • Do NOT use the raspberry pi’s 5v to drive the water pump.  The relay’s load, (the water pump), MUST be supplied by an INDEPENDENT power source or you risk frying the Raspberry Pi and the Grove board.
1 Like

Hey, thanks for your response. What do you mean with short them together? I only have one wire from relay to the water pump, the other being from the power supply. I’ll make and send a drawing of my circuitry when I’m home.

2 Likes is the way I wired it. this is the relay.

I doubt it’s the actuator, it also did not work with a small motor. But I also don’t see why the relay could be at fault. It’s clicking accordingly and the led matches too.


Try this:

Take the two wires that connect to the relay from the battery and the pump and connect them together - the pump should work.

If the pump doesn’t work, then the problem is somewhere in that circuit - maybe the battery isn’t powerful enough to run the pump?

If the pump works, connect a light bulb to the battery and the relay and see if it lights.

Re: The relay.

The LED doesn’t indicate that the relay contacts inside the box are good, it only indicates that the relay is being commanded to energize.  The LED would work even if the relay were completely missing.

As you may know, relays have two parts:

  • A magnet part
  • Contacts that are activated by the magnet.

Sometimes the contacts themselves don’t work even though the magnet does.

1 Like