Grove Shield and GroovePi Python Library


#1

Until my new GrovePi arrive, iam trying to connect my old Grove Shield for Arduino.

Following this post: http://blog.oscarliang.net/raspberry-pi-arduino-connected-i2c/
I am able to connect my Arduino with Grove Shield with the Raspberry Pi via I2C connection.
Then i run sudo i2cdetect -y 1 , i get the correct “04” that GrovePi “Setting up Software” points.

After that then i run a simple grove_led_blink.py , I getting error.
Rerunning sudo i2cdetect -y 1, i see my connect with “04” not to appear any more.

My initial investigation was to delete from ./install.sh the part that fetchs #Adding ARDUINO setup files can keep my working Arduino files from the post that i mention above.

But still no luck.

Do you have any suggestions? I believe that after achieving a I2C connect of Arduino Grove Shield and Raspberry Pi,it should been easy to use GroovePi Python library.


#2

Hi,
It should indeed work the way you are trying. Just a few pointers:

  1. Make sure that you are using 3.3V level conversion b/w the arduino and the Raspberry Pi.
  2. Make sure that nothing is connected to the I2C pins on the Arduino.
  3. Make sure that you are burning the GrovePi latest firmware https://github.com/DexterInd/GrovePi/tree/master/Firmware/Source/v1.1 .

It can also be a problem due to long wires or I2C pullups. I cannot be sure about this.

If you have already ordered the GrovePi, I’ll suggest you to wait for it. It might save you a lot of time to get things to work.

Let me know if this works and if you need any more help.

Thanks,
Karan