GrovePi+ and Chainable RGB LED


#1

Hi,

I have a Rpi2 with GrovePi+ and Grove Chainable RGB LEDs (chain of 3).
I can’t even make the Python sample grove_chainable_rgb_led.py.
First, I adjusted the code to run with ‘numleds=3’.
Then the ‘pin’ parameter for the chainableRgbLed_* functions wasn’t initialized. I chose to use the same value as for the ‘chain’ variable; 7 as the LEDs are connected to D7.
Now the scripts runs but nothing happens at all. The LEDs stay lit with a nice continuous light blue :slight_smile:


#2

Hi,
Can you just make sure that you are using the latest firmware and that you did a firmware update on the GrovePi+. The RGB LED code was added to the firmware a few weeks back. Can you try updating the firmware and let us know if that works.

-Karan


#3

My Pi2 and Grovepi+ are only a week old :slight_smile:
I did an update 2-3 days ago.
But I don’t know how to check what firmware version is running (see http://www.dexterindustries.com/forum/?topic=grove-pi-firmware)


#4

Hey,
Run grovepi_version_check.py https://github.com/DexterInd/GrovePi/blob/master/Software/Python/grove_version_check.py. It should report back 1.2.2 . If it reports anything else, update the GrovePi folder and run the firmware update script.

-Karan


#5

It reports 255.255.255 :frowning:
(see http://www.dexterindustries.com/forum/?topic=grove-pi-firmware)


#6

Hey,
Can you run it a few times and see if it still reports the same.

Id the version.txt file having 1.2.2 in GrovePi/Firmware. Did you try running the firmware update script here: GrovePi/Firmware/firmware_update.sh

-Karan


#7

Version.txt did show 1.2.2.
Following your suggestion I ran the firmware update script.
Now grovepi_version_check.py show the proper firmware version and my chainable RGB LEDs now blink like a Christmas tree :slight_smile:
Thanks a lot Karan for helping.

Benoit


#8

Hi, I have the exact same problem like Tariflette: I do not get the chainable LED script running. I use GrovePi+ with Paspberry Pi B+ and have a chain of two leds connected at D7 like described in the script. When I connect them, they are lighting. When I start the script, I am not able to change anything to the leds. I also checked my version.txt and found v1.2.2. When I try the firmware update, I am prompted to connect some pins for the update. But as I am not able to figure out which ones (the provided image is not for GrovePi+ with Raspberry), the update canceled. Can you advise me, what to do?

Chris


#9

Hey Chris,
You should just go ahead proceed with the Firmware update. The wiring instructions we for an older version of the GrovePi. Do check the firmware update guide here: http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/updating-firmware/ if you face any problems.

Do let us know if this helps.

-Karan


#10

Hi Karan,

after a successfull download from github repo the firmware_update.sh finally fails with “Firmware not found - Check if firmware is there or run again”.

What can I do?

Chris


#11

Update: In the post above I tried to update from the folder on Desktop. If I switch to /home/pi/GrovePi/Firmware and exec firmware_update.sh it says “AVR device not responding, initialisation failed, rc=-1”…


#12

Hey,
Can you try running sudo avrdude -c gpio -p m328p and post what you get. Also try running the install script as root by adding sudo before you start it.

-karan


#13

Hey,

sudo avrdude -c gpio -p m328p
returns the following: AVR device initialized and ready to accept instructions avrdude: Device signature = 0x1e950f avrdude: safemode: Fuses OK avrdude done

I already starting the firmware update script with sudo right.

Chris


#14

Hey Chris,
Can you post the full error that you are getting in the Firmware update process. That should help us figure out the problem.

-Karan


#15

Hi Chris and Karan,

I reported the chainable led problem one year ago on this forum.
This is therefore a very old issue that was never solved…

Hi Karan, do you remember that in October 2015 yo promised me to tat it on one of your systems.
Have you tried it in the mean time?

Should we just forget about it?

Regards,

Freddy


#16

discussion moved to Chainable LEDs[SOLVED]


#17