GrovePi+ & DHT11 & Rasbian Stretch Fails

grovepi
stretch
dht11

#1

Hi I’m using a DHT11 with Grovepi+ and Rpi3, ive managet it to run everything including boot with serial interface enabled (by disablin BT), my problem is

that the dht11 always shows -1C and humid -1%
i’ve checked the sensor with an arduino, sensor works properly.

Pleas help.


#2

Hi @AnySolution,

First of all, can you tell us what script had you been running? Also, what DHT sensor do you have? Is it the white one or the blue one?

Second of all, all of our products haven’t shifted to Stretch yet, mainly because Stretch is still buggy and new to the market and we need to have the proof of time before jumping in it. So at the moment, we don’t support Stretch, yet.

Even so, please answer the first 2 questions so we can see if there’s something to do about it.

Thank you!


#3

Hi Robert,
I’ve orderd the GrovePi+ starter kit incluting the DHT11 sensor as described in the text above, as i gues dht11 are always blu and dht are the white ones.

I’ve flashed a new card with rasbian for robots and tried your demoprogram as well (grove_dht_pro_filter/grove_dht_example3.py) shows also -1°C

I think there is something fucked up.

kind regards Simon


#4

I am having the same problem, been stuck on it for a while. I have just flashed Raspbian For Robots, ran all the tests and the logs look OK, but still the problem.
Have finished the rest of the project just now waiting for these values to be “fixed”! The LCD works fine, but I don’t have any other sensors to find out if its a faulty DHT sensor. I have the blue one.


#5

Are ther AnySolutions until now?

@Sodex I’ve tried the sensor with an arduino and tred also other sensors like the lightsensor they work but noth in combination with raspberry and grovePi+


#6

Hi @AnySolution, @sodex234,

I’ve followed the next steps on my Raspberry Pi:

  1. Updated GrovePi by typing the sudo curl -kL dexterindustries.com/update_grovepi | bash command. This command can also be used for installing the GrovePi library on a fresh Jessie distro.

  2. Updated the firmware of the GrovePi.

  3. Connected the DHT sensor (the blue one) to the digital port 4 (of the GrovePi) and then I ran grove_dht_example3.py script with Python3.

Here’s what I got after I did all these steps:

So it worked for me.

What I think is that you have the white sensor. That’s because when there’s a mismatch between these 2 sensors, you’ll get -1 as values. Could you make a photo of your setup and attach it here so we can give it a look? I want to exclude the possibility of an improper setup.

Thank you!


#7

Hi Robert, thank you verry much for this update, but i think there is stl a bug.

#DHT basics
#Sensor on Digital Port 4

from grovepi import dht
import signal
import sys

sensor=4
bluesen=0

while True:
    [temp, humidity] = dht(sensor, bluesen)
    t=str(temp)
    humi=str(humidity)
    print("Temp="+t+" Hum="+humi)


It runs ok as your Code does, yet hangs up after a while and i have to repower the board that it starts to work again, what could it be?

Thanks for your help
Simon


#8

Hi @AnySolution,


What do you mean it hangs up?
Does it throw an error or it just stops printing values?

Another thing I can see is that in your previous post you are talking about the grove_dht_pro_filter/grove_dht_example3.py file, whilst in your last post you’re talking about the dht function of grovepi module. With which thing do you have issues?


If you run the grove_dht_pro_filter/grove_dht_example3.py example and at some point, you stop seeing an output (aka it hangs up), it could be because there is so much noise on the cable that the GrovePi can no longer communicate with the sensor. Or it could be that the sensor has been unplugged.

On the other hand, running the quoted script by you (which uses the dht function from the grovepi module) should never stop printing data. If the sensor is not connected, the dht(sensor, bluesen) should output a (-1, -1) tuple.


I’m waiting for an input from you.

Thank you!