GrovePi i2c seems to be disconnected


#1

Hi.

I’m using GrovePi Starter Kit.

I’ve programmed an app which continuously senses values of some sensors such as light, temperature/humidity, and so on with Raspberry Pi 2 and GrovePi board.

However, it cannot get sensing values after a few days working.

At the time it doesn’t work, ‘i2cdectect -y 1’ doesn’t show ‘04’.


     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

(Of cource, it shows ‘04’ when it works well.)

How can I solve this issue?

If it cannot be solved, could you please guide me how to reset GrovePi without rebooting Raspberry Pi 2?

Thank you.


#2

This is a bit strange. Can you follow the instructions here and run the troubleshooting script for the GrovePi and upload log here: https://www.youtube.com/watch?v=ZMadpIEYq5o. That would really help us to solve the problem.

Also, to reset the GrovePi from software you can use: avrdude -c gpio -p m328p from the terminal or you can use subprocess library to call it from python.

-Karan


#3

Thank you very much for your guidance.

By the way, I’m using Raspberry Pi 2 and GrovePi not on Dexter Industries’ version OS image but on normal Raspbian - 2015-05-05-raspbian-wheezy.img.
I’ve worked on this image, so I can’t follow your guidance for test log.

I’ve got the source of GrovePi from Github repository, git@github.com:DexterInd/GrovePi.git.
But, I don’t know how can I get the test log which you request from this repository.

Could you guide me again, please?

Thank you.

Regards,
Jaeseok

P.S. I’ve tried to reset my GrovePi as you guide me, however it shows an error message.


root@jspi:~/th# avrdude -c gpio -p m328p

avrdude: Can't find programmer id "gpio"

Valid programmers are:
  2232HIO          = FT2232H based generic programmer
  4232h            = FT4232H based generic programmer
  arduino          = Arduino

...



#4

I think you’re best bet is to image Raspbian for Robots on an SD Card. The video Karan refers to is specifically for Raspbian for Robots.


#5

Is it difficult to solve this issue on my environment - normal wheezy Raspbian image?
To set my environment to new image is quite difficult to me.

I’ve update the firmware of GrovePi from the old version to the latest version, v1.2.2 with Dexter’s image.
But I have some private reasons that I should develop my application on the normal wheezy Raspbian image.

Please help me.

Thank you.

Regards,
Jaeseok


#6

Hey Jaiseok,
Can you download and tun this script here: https://github.com/DexterInd/GrovePi/blob/master/Script/install.sh and then try updating the firmware following the instructions here" http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/updating-firmware/. It might be better to clone the repo first and then try this.

-Karan


#7

Hi Karan,

Always thanks for your reply.

Before I wrote this issue thread, I’ve already tried to update the firmware with that script on my environment(on the common wheezy Debian image).
However, it failed with the below error:

avrdude: Can't find programmer id "gpio"

To update the firmware, I’ve updated the latest firmware v1.2.2 with a new SD card and Dexter’s OS image.

Though the firmware has been updated, the error that i2c doesn’t work still occurs in my app on my wheezy image.
(But, it seems to occur rarely than the old version firmware.)

In conclution,

  1. The firmware version of my GrovePi board is v1.2.2.
  2. I used Dexter’s image for only updating the firmware. After update, I work on my Debian image because GrovePi firmware is not concerned with the OS image.
  3. On my Debian image, i2c issue has still occurs but rarely than before update.
  4. How can I add programmer id “gpio” for avrdude? If it works, I can run the script for check the status of my environment and can report it to you.

Thank you.

Regards,
Jaeseok


#8

Hey Jaeseok,
We recommend using this script https://github.com/DexterInd/GrovePi/blob/master/Script/install.sh on your own image. This would set up all the software packages, make the necessary settings and install avrdude properly too. If you are only interested in installing avrdude, then that is on lines 164 to 172.

-Karan