GrovePi Installation Issue

I’ve been trying for hours to set up Grove Pi on a Raspberry Pi 3 Model B+. I tried the detailed installation process, and it wouldn’t run the install executable. I tried to remove what I could and try the quick setup, which partially installed parts of GrovePi. However, it did not install the GrovePi firmware as far as I can tell because the Troubleshooter keeps freezing while checking for the firmware version. I’m not sure what to do to fix this issue.log.txt (6.4 KB)

It’s not clear to me to what instructions/tutorial you are referring to. Regardless, I’m going to assume you’re starting from a clean state. Here’s how.

curl -kL | bash

Run that and then reboot your Pi. It needs that if you do it on a fresh Raspbian image.

After the reboot, flash the firmware by navigating to /home/pi/Dexter/GrovePi/Firmware and running bash That should flash the GrovePi just fine.

Now, you can run the built-in troubleshooter. You should see address 0x04 appear as an I2C device.

Thank you!