GrovePi Sensors don't work or analog sensors don't work [SOLVED]


#1

In the last few weeks we had seen a couple of posts where people were unable to read from the analog sensors and some other sensors too but were able to run the LED blink example.

We have found the problem with the board and it was because of the fuses being set incorrectly on the firmware which reduced the clock speed to 1/8 the of the original and caused the problem. There is a script attached to this post and running that on your pi should make the problem go away. To run the script, make it executable: sudo chmod +x grove_setup2.txt and run it: sudo ./grove_setup2.txt.

Do let us know if this works for you.

-Karan


#2

Please let us know if this solution works for you! If it does, we’ll update the Github repository and come up with a fix on the manufacturing side. Thanks!


#3

Thank you for the solution. The light sensor works ok, though with some errors


#4

I can confirm - analog inputs work but with DI image. Could somebody confirm that it also works for him with a system setup manually using instructions from github:
http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/

Thank you for fixing it!
Radek


#5

Hey Radek,
I just tried the install script with the Latest Raspbian image 2015-05-05-raspbian-wheezy and everything is working properly with the GrovePi. I didn’t face any problems with the GrovePi.

It would be great if you could share more details about the problem that you are facing.

-Karan


#6

Hi Kiran,

no problem I just would like to confirm with you the procedure. Is that the procedure you followed:
http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/
after downloading image from:

I have RPi V2 B and this procedure was not sufficient to get my Pi to work. I had also to update /etc/modules as described here:


One would hope that the installation script would do it.

If you could confirm your procedure - I could try it.

Cheers,
Radek


#7

Hey Radek,
That’s the exact procedure that I followed. Just do a sudo apt-get update before you start the script to make sure that all the package links are updated.

Also make sure that you have the latest version of the install script and the git repo from here: https://github.com/DexterInd/GrovePi .

Do let us know how it goes for you and if you face any problems.

-Karan


#8

Hi Karan,

I just tested with an image from git: number of problems = 0.
Everything works in my setup - even analog sensor without any special actions or deviating from installation procedure right of the bat.

Thank you for all the info and support!

Cheers,
Radek


#9

Wow. Just got here after wondering what the hell I did wrong, why I would get 899-900 out of the light sensor, whether night or day, and luckily found this. I haven’t tested the other sensors yet, but the light sensor is suddenly responding with meaningful readings, so I trust the others are good, too.

Thanks!

This is with a RasPi from a couple of years old (model B, I guess?) with GrovePi+ on Raspbian with github config for GrovePi


#10

Hey jaythvv,
How did the tem/hum sensor far overnight. Can you also share the code thaqt you were using to test them so that we can have a look at them and try to replicate the problem at our end.

-Karan


#11

Hi Karan,

Sorry for the slight delay. The temp/hum sensor as well as light are working fine, be it without my sound and ranger scripts.

These send results up to a cloud server, but I have commented that stuff out, and should now just print the body of the message. If you get any errors, it’s likely http related and you should be able to remove it. The scripts use the grove_rgb_lcd scripts which I didn’t change so I didn’t include.

I run these scripts from cron: (last two commented out here, of course, but to test you wouldn’t)

*/2 * * * * sudo <path_to>/ho_temp_hum.py
*/2 * * * * sudo <path_to>/ho_light.py

*/5 * * * * sudo <path_to>/watchdog.sh <path_to>/ho_sound.py

*/5 * * * * sudo <path_to>/watchdog.sh <path_to>/ho_ranger.py

The watchdog.sh script simply checks if the process runs, and start it if it doesn’t. For testing, you might just want to run those scripts directly from the shell.


#12

Hey jaythvv,
We’ll try out the scripts and get back to you.

-Karan


#13

Hey guys, I’m going to close this thread. This problem is solved, that’s awesome,but now it’s been hijacked with a new discussion on crontab.


#14

Hi Karan,

I apologize in advance if I am missing it … however, I don’t see where this grove_setup2.txt file is attached on this post.

Thanks in advance for your help.

Cheers,

Chad


#15

Hi @chad.modad,

The GrovePi platform changed significantly since 2015, software-wise.

I’m also looking at these replies and at this moment, they no longer seem relevant.
Can you tell us what you’re trying to achieve? We will gladly help you.

By the way, if you’re interested in just installing the GrovePi, please take a look at the GrovePi's README in here:

Thank you!