GrovePi UART Rx pin on RPi2


#1

Hi,

I am working on Raspberry Pi 2 + GrovePi with Snappy Ubuntu Core (15.04), and I find the initial status of GPIO 15 (UART0 RX) is different after plugging GrovePi to RPi2.
I flash the the Ubuntu core to RPi2 and power on, the uboot counts down and auto boot into Ubuntu core normally,
but when I plug GrovePi to RPi2, the uboot stops autoboot and goes to prompt, but when I connect UART to my laptop, uboot becomes normally again (auto boot into Ubuntu) and UART works fine.
It looks uboot considers there is a key pressed from UART at the first power on when plugging GrovePi to RPi2 without UART connected,
so I try to measure the GPIO 15 / UART Rx and find that without GrovePi plugged, the initial status of GPIO 15 is high but when GrovePi plugged, the GPIO 15 initial status becomes low.
It leads to uboot stop autoboot, I also check the schematic GrovePi+_2.2_schem.pdf from https://github.com/DexterInd/GrovePi.git, it looks GPIO15,UART0_RXD is connected to RPI-RX directly,
Currently I just connect GPIO15 to a 5V pin, then it works fine but it doesn’t seem right, so I wonder why the initial status is changed or is there anything I can do without connect GPIO15 to a 5V pin?

Thanks!!
Gerald


#2

Hi Gerald,
We haven’t use Snappy Ubuntu Core before so cannot really say a lot about the source of the problem. The UART pins are connected to the Grove header via a 3.3V to 5V level converter and I think that the level converter might be pulling it high/low when it powers on, but we are not really sure what’s happening with your Pi. I’ll check the logic level on the UART pins later today with Raspbian to see what exactly happens with the pins during boot. Would it be possible to disable the code/script which looks for a button press during boot so that you can skip that check.

-Karan


#3

Hi Karan,

Thanks for your reply, I can modify uboot to disable checking the key pressed, but I possibly still need to use uboot prompt in the future,
in this case, uboot needs to be modified again to enable it, so I think I will keep the current way I do,
but if you find anything about this, please let me know.

Many thanks,
Gerald


#4

Hi Gerald,

I recently bought a GrovePi+ board. The product link is at https://item.taobao.com/item.htm?spm=a1z09.2.0.0.z80kOK&id=45475491903&_u=oqtus999afa. Today, I tried to connect the board to my RaspBerry Pi 2 board. However, the system cannot be successfully booted. I cannot see the blinking light of the Ethernet port. If I take off the GrovePi board, everything is fine. For your information, I flashed the RaspBerry Pi 2 image at the following link:

http://cdimage.ubuntu.com/ubuntu-snappy/15.04/stable/latest/

Do you have the same problem?

Thanks & best regards,
XiaoGuo


#5

Hi Karan,

Currently, snap app runs on its own sandbox. I cannot make a step-by-step configuration for the grovepi according to the instructions at:

http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/

Do you if there is any method to enable the grovepi on my snappy ubuntu core? I am currently doing some demos on top of it.

Thanks & best regards,
XiaoGuo


#6

Hi XiaoGuo,
I think it might be the same problem Gerald was talking about. For some reason the GrovePi is changing the UART pin GPIO 15, so you’ll have to pull GPIO15 to a 5V pin with a jumper or something else.

We are still looking into the issue and will let you know if there is a software solution to it.

Do let us know if this helps.

-Karan


#7

Hi Karan,

Thanks for your help on the issue. Yes, I did it at Gerald’s suggestion, and now I can successfully boot my RaspBerry PI device. I have one more problem for it. I cannot find the i2c bus number 4 device in my snappy ubuntu core unless I do some installations according to the link http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/. On my current installation, I can only see /dev/i2c-1 device. One problem for snappy core is that every snap runs in its own sandbox. The installation is not so straightforward. Also some of the links are blocked in China like the one “git://git.drogon.net/wiringPi”. I am think whether it is possible to enable the grovepi on the system level so the device will be straightly available to apps.

Thanks & Merry Christmas,
XiaoGuo