Having trouble connecting with wifi


#1

hello everybody,

So I have downloaded the most recent image of raspbian for robots and I am having trouble connecting to the GoPiGo through my wifi. I have setup the wifi n the GoPiGo and its connects to the wifi. But when trying to connect to the GoPiGo with my computer using wifi I cannot get a connection. Any help would be appreciated.


#2

Hello! Sorry to hear about the trouble connecting. Have you first tried to connect first over ethernet?

I would try the directions here: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/4-connect-to-the-gopigo/

Under Option 2, can you tell us where you get stuck? Be sure to remove the wifi dongle before starting this process. Once you’re connected via ethernet, you can insert your wifi dongle, and then setup the wifi network.


#3

Yes I can connect with Ethernet. And I have setup the GoPiGo to work with wifi. The trouble that I am having is when I am trying to control the GoPiGo while not being connected by the Ethernet cable. So just to reiterate I can do 2 things. 1. connect to it using an Ethernet cable. 2. Connect the GoPiGo to the Wifi.
The one thing that I cannot figure out is connecting to the GoPiGo (from my laptop) over the wifi and control the robot remotely without any cables connected to the GoPiGo.

I have looked at the that website a hundred times and it does not help for this particular step. Thank you for the advice and any help that you guys give I look forward to getting this to work. :slight_smile:

Best Regards,
Metabee


#4

Hey Metabee,
Ok, great! That clears things up, thanks for re-explaining. It sounds like your Pi is connected to the wifi network. Is your Pi and your computer on the same wifi network? Are you able to ping the Pi from your laptop? The local IP addressing we refer to in our directions (dex.local) only works between your computer and the Pi when they’re on the same wifi network.

John


#5

yes they are on the same wifi network. when trying to remote login to the Pi I have tried dex.local and the actual ip address and it still doesn’t work.


#6

Ok, good to know. Two more questions:
1). Have you disconnected the Pi from ethernet?
2). Have you tried to ping dex.local or raspberrypi.local? What happens when you ping those two addresses?


#7

when you say disconnect the pi from ethernet do you mean a step by step process or do you mean simply unplug it from the ethernet.

And yes I can ping dex.local while it is connected with the ethernet cable.


#8

When you are connected to the Pi via Ethernet, can you run ifconfigand iwconfig commands on the Raspberry Pi and post the output that you get there.

-Karan


#9

So if you can ping dex.local, the computer and the Pi are connected and talking. If you pull up a Mozilla browser and type in the address dex.local, do you get anything back?


#10

pi@dex ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:0e:aa:21
inet addr:169.254.91.105 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:141 errors:0 dropped:0 overruns:0 frame:0
TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15896 (15.5 KiB) TX bytes:14797 (14.4 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr e8:4e:06:2b:bc:6b
inet addr:192.168.1.18 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:53 errors:0 dropped:1 overruns:0 frame:0
TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8662 (8.4 KiB) TX bytes:18887 (18.4 KiB)

pi@dex ~ $ iwconfig
wlan0 IEEE 802.11bgn ESSID:“NETGEAR19” Nickname:"<WIFI@REALTEK>"
Mode:Managed Frequency:2.462 GHz Access Point: C4:04:15:51:48:0C
Bit Rate:72.2 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=100/100 Signal level=100/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

pi@dex ~ $

this is what shows up when i type those two commands ifconfig, iwconfig.

When I pull it up from mozilla I get the desktop as I would from VNC viewer.(that is only when I have it connected by ehternet though)


#11

Hi,
From your information in the log above, can you first try using the ip mentioned in wlan0 in ifconfig to connect via SSH. In the above log it’s 192.168.1.18:
wlan0 Link encap:Ethernet HWaddr e8:4e:06:2b:bc:6b
inet addr:192.168.1.18 Bcast:192.168.1.255 Mask:255.255.255.0
.

If that works, can you try using dex.local next.

-Karan