Help. Cannot import name Mutex


#1

I’m using GOPIGO3 start kit, and it works with DexterOS 1.3. When I transfer to CINCH(2018.1.29 version) system,
use the following
curl -kL dexterindustries.com/update_gopigo3 | bash to update gopigo3 to version 1.2.0.
Test python using run_this.py under BasicRobotControl folder. The error shows Cannot import name Mutex.
Then using the following :

sudo rm /usr/local/lib/python2.7/dist-packages/gopigo3*.egg
sudo rm /usr/local/lib/python3.4/dist-packages/gopigo3*.egg
cd ~/Dexter/GoPiGo3/Software/Python
sudo python setup.py install
sudo python3 setup.py install

but the issue can not be fixed. Still not works.


#2

Hi @574240324,

You’ll need to have internet connection in order to run the following command:

curl -kL dexterindustries.com/update_rfrtools | bash -s – --install-python-package --use-python3-exe-too --update-aptget --install-deb-deps

This should get the I2C_mutex installed back in.

We are undergoing a couple of changes lately and this is the cause of it.

Thank you!


#3

thanks your support. after running the command, get the following:

The following NEW packages will be installed:
  libwxbase3.0-0 libwxgtk3.0-0 python-wxgtk3.0 python-wxtools
0 upgraded, 4 newly installed, 0 to remove and 276 not upgraded.
Need to get 9,527 kB of archives.
After this operation, 43.6 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libwxbase3.0-0 libwxgtk3.0-0 python-wxgtk3.0 python-wxtools
E: There are problems and -y was used without --force-yes
Installing TroubleShooting
Done with TRoubleshooting
pi@dex:~/Dexter/GoPiGo33/Projects/BasicRobotControl $ python3 run_this.pyTraceback (most recent call last):
  File "run_this.py", line 26, in <module>
    from keyboarded_robot import GoPiGo3WithKeyboard
  File "/home/pi/Dexter/GoPiGo33/Projects/BasicRobotControl/keyboarded_robot.py", line 22, in <module>
    import easygopigo3 as easy
  File "/usr/local/lib/python3.4/dist-packages/gopigo3-1.2.0-py3.4.egg/easygopigo3.py", line 11, in <module>
ImportError: No module named 'I2C_mutex'

Still get I2C_mutex error issue.


#4

it seems it works if I use python run_this.py under BasicControl folder. Python3 doesn’t works. I test RemoteCamera projects, get the following output log:

pi@dex:~/Dexter/GoPiGo33/Projects/RemoteCameraRobot $ sudo python3 flask_server.py
Error: No module named 'flask'
Error occured!  Make sure that your ran this program using python3!
Try again with the command sudo python3 flask_server.py
Traceback (most recent call last):
  File "flask_server.py", line 25, in <module>
    gopigo3_robot = EasyGoPiGo3()
NameError: name 'EasyGoPiGo3' is not defined
pi@dex:~/Dexter/GoPiGo33/Projects/RemoteCameraRobot $

#5

Hi @574240324,

The errors you’re getting don’t make much sense. Can you tell us if you have internet access on your Raspberry Pi?
To put it in a few words, Cinch doesn’t have internet access by-default, whereas Raspbian For Robots has. Probably, you’re running Cinch without internet access and that’s the reason you’re getting all those.

Thank you!


#6

I do have internet access using CINCH via Ethernet cable and USB adapter connected to my MAC(Share my MAC’s internet). I have updated the GOPIGO3 to V1.2.0 and run the commands you provided. But now python3 doesn’t work, and some python2 command works(eg. BasicControlRobot works). Could you please tell me where is the latest DexOS2.0 I can download. And Also the latest version of Raspbian PI for Robot . Thanks


#7

Hi @574240324,

It doesn’t make any sense not seeing this working.

Fortunately, we have just released a few hours ago a beta for Raspbian For Robots that works on Stretch distribution.

To get this beta of Raspbian For Robots, please check the following pinned post:

As for DexterOS 2.0, you could find it by Googling but here is the answer to it:

https://www.dexterindustries.com/dexteros/get-dexteros-operating-system-for-raspberry-pi-robotics/

Thank you!


#8

Hi Robert,

Thanks for your stretch version. The issue of mutex
Is fixed. The basic control for GOPIGO3 works well. Hower,I still have question as following:

  1. this version of Raspbian stretch does not
    Broadcast automatically WiFi ssid ”dex” but Dexos do,how to set up?

  2. I test the example of RemoteCamera ,and the control works well but video stream doesn’t work(waiting video stream always held on html page). It seems the uv4l driver lead to that. While
    The setup for install is for Jessie version may not
    Works for stretch version. Could you please help me fix it.Thanks


#9

Hi @574240324,

Well, the Cinch OS you used broadcasts a WiFi AP with dex SSID, but this doesn’t show up on regular distributions (Stretch, Raspbian For Robots, etc). One way to set it up is to sudo bash cinch_installer.sh from https://github.com/DexterInd/Raspbian_For_Robots/tree/master/upd_script/wifi. You can find the script in /home/pi/di_update/Raspbian_For_Robots/upd_script/wifi.
To uninstall it, use sudo bash cinch_uninstaller.sh.

As for the Remote Camera project for the GoPiGo3, that’s a very good observation. I’ll have that project fixed ASAP. I’ll come back with an answer as soon as I have something.

Thank you!


#10

Hi Robert,
Got it. I will appreciate if you put the final released version of DexterOS 2.0 image into the sourceforge.net. The download process from dexterindustries .com always failed due to CRC check error.


#11

Hi @574240324,

We haven’t had this problem so far - literally, I tried on mine and I’m not getting this problem.

Either way, we’ll take your request into consideration and decide what other provider to use along with the current one.

Thank you!


#12

Hi @574240324,

We came back with a fix for the Remote Camera Project and we made it work on Stretch.

Unfortunately (though I don’t think it’s that of a big issue), it seems like the UV4L libraries are no longer maintained for Jessie or Wheezy, so if you want to have this running, you have to use a Stretch distribution. Fortunately, we’re moving Raspbian For Robots (and whatever we have on our plate) to Stretch, so it’s all going to be well “integrated”.

The PR that fixes this issue can be found here:

In the following couple of days, this fix will be put on the master branch of our repository, so stay tuned.

Thank you!

Edit: We added support Jessie too, even though the libraries are no longer maintained. This is for our users that still work on Jessie.