Help with logging on


#1

I need some help with logging onto the bot. I was able to originally log on to the bot with the Ethernet. I set up my WIFI network. I turned to bot off and disconnected it from the ethernet cord. After turning the bot back on, I was unable to log on. I tried reconnecting to the ethernet and it would not connect.

I have disconnected the wifi dongle. Still no connection.

I have two green lights on the ethernet port. The raspberry pi has red and green light in the front. It wont connect.

Any clues?

Thanks.


#2

Hey Emanoh,

After you log on with ethernet and setup wifi credentials on the Raspberry Pi, are you able to complete the step where you ping google.com from a terminal, on the Raspberry Pi?

Also, after you connect over wifi, and shut the robot down and disconnect the ethernet cable; and then power the Pi back up. Are you able to ping dex.local over the wifi network?

Thanks,

John


#3

I was able to ping dexterindustries website. The bot was setup. I disconnected and now I am not able to connect with wifi or ethernet cable.


#4

I just briefly had an issue with logging on after logging on successfully. I had the batteries connected but without the power cord and couldn’t log on though all the right lights were flashing on the pi. After I connected the power cord again the log on worked. I recharged the batteries and log on was okay with battery power only. It seemed that the lower battery charge affected the log on. I noticed that the lights were all brighter after recharge or with power cable as well. Could it be that?


#5

I tried connecting to the power cord. No results.

I disconnected my wifi dongle and turned off the wifi on the computer and still no response.

What else can I do?

I see the ethernet lights working and even I see the gopigo lights work.

Do you think the raspberry pi went bad? or the microSD card went bad?

Should I try to write a disk image on another microSD card?


#6

Emanoh, it sounds like you’re having network troubles, not problems with the sd card or the Pi. This is a software issue, not a hardware issue.

When you’re trying to connect over the wifi network, is your PC or Mac connected to the same wifi network? They’re both logged in to the same SSID and wifi network, right? If you start the Pi up with just the wifi dongle in, do the lights on the wifi dongle blink? Are you able to ping dex.local once the Pi is fully started?

Humanoid makes a great point: when you’re getting setup, be sure to have the USB power cable in the Pi; this rules out any battery issues.


#7

I am not able to log in with either the wifi network or local ethernet cord. I did use the power cord to power on the bot. It did not help.

I do see lights on the wifi dongle. I have even turned off my anit-virus software. Nothing helped.


#8

So an update. I was able to connect the robot to a monitor. I saw that the raspberry pi did all of its checks and I saw the desktop. So I now know that the robot is working.

I tried to log on to the robot and I am unable to either via ethernet cable or wifi while connected to my computer. I have windows 8.

Suggestions?


#9

When you have it setup as a desktop, pull up the command line. Setup the Pi as you would expect it to work with the ethernet cable connected. Can you please run sudo ifconfig.

Can you paste the output into the forums, or into a text file and upload it to our forums?


#10

Here is the info you asked for.

I also deleted the wifi network associated with the bot. I tried to connect to another wifi network and it states that it cant get status from wpa_supplicant


#11

I also disconnected the wifi dongle. I was unable to connect via the ethernet or going via browser to http:/dex.local.

I used the virtual vnc app mentioned in another thread.

I was able to go to the ip address but I was not able to log onto the website. I get an error 1006.


#12

Attached file


#13

It looks like you’re connected to both the ethernet and the wifi networks. It looks like you can ping the device from your PC or Mac.

To ping ethernet, can you run “ping 169.254.1.0”

To ping over wifi, you can run “ping 192.168.252.125”

If you have restarted your Pi, you might have different IP numbers. YOu might check for it again, these are behind “inet addr:” when you run ifconfig on the command line.

So if you’re still unable to ping dex.local, you might need to assign a static IP for the Pi to work on your network. Have you tried that yet?


#14

Thanks for the help. I was able to fix it but not by your suggestions.

I ordered another raspberry pi and connected it to the robot. I was able to log on and test the robot.

When I tried with the original raspberry pi, I wasnt able to log on.

Not sure what happened but my son and I are happy that we could use the robot.

Thanks again for the help and I know I will be back asking newbie questions.


#15

So to confirm, the problem was with the Raspberry Pi B+?