Highest compatibility of BrickPi+?


#1

Hi,
I’ve got a BrickPi+. My raspy B is done, so what would be the newest Model to work with without hassles?
Pi 2 Model B
Pi 2 Model B v1.2

Pi 3 Model B
Pi 3 Model B+
thanks for information!
A.


#2

The BrickPi+ scripts don’t support Raspbian Stretch, so I recommend either RPi 2 with Jessie (or Wheezy) or RPi 3 (not 3B+) with Jessie. RPi 3B+ won’t work, since it requires Stretch, and Stretch isn’t supported by the BrickPi+ scripts.


#3

Let me add that the Scripts don’t support the BrickPi+ but the BrickPi in theory should work with Stretch. Specifically I infer you mean this command: sudo curl -kL dexterindustries.com/update_brickpi_plus However if it is installed with sudo python3 setup.py install shouldn’t that work regardless of the platform? I tested this on Stretch and I was able to successfully import the BrickPi module.

So perhaps it is not officially supported but it definitely should work on the RPi 3B+ with raspbian stretch with absolutely no pain. I use a RPi 3 for the record.


#4

Yes, I’m sure it can be made to work with Stretch. Raspbian for Robots Stretch doesn’t support it.

You would probably have to manually install the Python packages (as graykevinb said) and configure the UART pins. It’s not 100% ready to go, but it shouldn’t be too difficult to make it work.


#5

Configure UART pins? I’m confused, I never remember doing anything but installing the python modules
for the BrickPi+. I was using stock Jessie though.


#6

Thanks for the quick and precise Information :slight_smile:

Sunny Regards from cologne.

dse nchrcht wrd vn ntrwgs gsndt

bs bld

Anno.

0221 - 510 11 27

0151 - 25 366 545