Home_temp_hum_display project IOerror Errno 13


#1

Hello,

I’ve set up my grovepi with the latest firmware and updated the library. My pi shows correctly on output 04 and I can get the led to blink using the blinky.py. I am now trying to run the home_temp_hum_display project but all I get is a string of IOerrors. This is the data I have been able to find so far:

Traceback (most recent call last):
File “/home/pi/Desktop/GrovePi/Projects/home_temp_humi_display/home_temp_hum_display.py”. line 7, in <module>
from grovepi import *
File “build/bdist.linux-armv71/egg/grovepi.py”, line 22, in <module>
IOError: [Errno 13] Permission denied

On a related note, I can not seem to edit any .py files as I get the same error: [Errno 13] Permission denied

I would like to get this set up for a school project so any help would be greatly appreciated.

Cheers


#2

Whenever I get ‘permission denied’ I retry as root and that usually fixes it - just put 'sudo ’ at the start of the ‘python …’ line.

This isn’t ideal, better to give the correct rights to the user you normally run as, but I don’t know how to do that?


#3

Agreed with mamoulian: try putting “sudo” in front of your call:

sudo python filename.py

Care to share the project when you’re done? We would love to hear more!


#4

Hi,

Thanks for the quick response. I have tried using sudo first. I have tried when in su and when logged in as pi. I have tried ssh-ing as administrator. I have run the command directly with the pi as well as ssh-ing. I have also tried my pi image with all the appropriate firmware and software updates as well as the Dexter Industries image with all updates and firmware updated. I was able to edit the 1 to a 0 to indicate the DH11, I have tried it with the 1 in place, using both OS images with sudo nano.

I have been able to get the Oled to work independently in the past. The only reading I occasionally get about every 100 times the error is thrown up is:
temp: -1, humidity: -1

Any other thoughts would be greatly appreciated, I am trying to get this set up to monitor a grow chamber in the plant biology department greenhouse at the University I am doing research at so I really want to get it up and running!

Thanks


#5

What’s on line 22 in your grovepi.py? In mine it’s “import math”, which probably shouldn’t give “permission denied”.

If it’s something like
bus = smbus.SMBus(1)

then check the permissions for /dev/i2c* so that the python user can use it.

However, if blinkpi.py still works then it’s probably some other problem. Maybe you can check those lines mentioned in the backtrace?


#6

Hey,
I am also not sure what the problems might have been, but maybe the GrovePi library is installed as root and hece you don’t have access to it. You should try running sudo pip install grovepi ans see if that helps.

-Karan


#7

Hi,

No luck with any of the suggestion so far, anyone else have any thoughts?


#8

proconrpi, a suggestion and a question:

First, can you copy grovepi.py (find it here https://github.com/DexterInd/GrovePi/tree/master/Software/Python) to the example directory. Try running again with sudo.

Second, what version and rev of the Pi are you running?


#9

Hi, I’m getting an error too when running the Home Weather Display script. I’ve followed the tutorial directions and get this error:

Traceback (most recent call last):
File “home_temp_hum_display.py”, line 7, in <module>
from grovepi import *
ImportError: No module named grovepi

Please note my starter kit came with LCD RGB Backlight and the blue Temp & Humidity sensor. My GrovePi even looks different from the one in the tutorial.

I have not done any firmware upgrades. My Raspberry Pi 2 and GrovePi Starter Kit are from Seeed Studio.

Also, if it helps, the LED Blink script works without error.

Please help! Thanks!


#10

hopefully this thread will help:

http://www.dexterindustries.com/forum/?topic=no-module-named-grovepi

Also note that ‘home_temp_humi_display’ (lowercase) is for the OLED display not the LCD RGB - try ‘Home_Weather_Display’ instead. As you’ve got the blue sensor you’ll need to edit ‘Home_Weather_Display.py’ and set:
dht_sensor_type = 0
instead of 1. Make sure you’re up to date with GitHub first as there was a change to that file today.


#11

Thanks for the reply! Yeah, the Home Weather Display tutorial links to Home Temp Hum Display. These tutorials really need some attention. It’s a nightmare for noobs like myself.

I upgraded the firmware successfully and ran the setup.py script in the Python folder. Now I get a whole new can of worms when I run the Home Weather Display script. I’ll edit the script like you said though. I think that may fix the new problem. Thanks again!