I am getting desperate, I can't get my GoPiGo3 to run even a simple script

Please help me, I’m about to give up and throw this thing out the window after spending tens if not hundreds of hours trying to get it to execute even a simple script.

Here’s my script:

$ cat test_01.py
from easygopigo3 import EasyGoPiGo3 # importing the EasyGoPiGo3 class
gpg = EasyGoPiGo3() # instantiating a EasyGoPiGo3 object

Not even a script, just trying to import a library.

I tried running it:

$ python test_01.py
Traceback (most recent call last):
  File "test_01.py", line 1, in <module>
    from easygopigo3 import EasyGoPiGo3 # importing the EasyGoPiGo3 class
  File "/home/pi/.local/lib/python3.7/site-packages/gopigo3-", line 13, in <module>
  File "/home/pi/.local/lib/python3.7/site-packages/gopigo3-", line 1, in <module>
ModuleNotFoundError: No module named 'I2C_mutex'

I spent hours and hours looking for solutions online.

Here’s the version:

$ pip freeze | grep gopigo3

Based on this thread: No module named I2C_mutex - #12 by anitatech

I tried:

$ sudo apt-get install -y build-essential libi2c-dev i2c-tools python-dev python3-dev python-setuptools python3-setuptools python-pip python3-pip libffi-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.6).
i2c-tools is already the newest version (4.1-1).
libffi-dev is already the newest version (3.2.1-9).
libi2c-dev is already the newest version (4.1-1).
python-dev is already the newest version (2.7.16-1).
python-setuptools is already the newest version (40.8.0-1).
python3-dev is already the newest version (3.7.3-1).
python3-setuptools is already the newest version (40.8.0-1).
python-pip is already the newest version (18.1-5+rpt1).
python3-pip is already the newest version (18.1-5+rpt1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.


$ cd /home/pi/Dexter/lib/Dexter
$ git clone https://github.com/DexterInd/RFR_Tools
Cloning into 'RFR_Tools'...
fatal: unable to access 'https://github.com/DexterInd/RFR_Tools/': Failed to connect to github.com port 443: Connection refused


$ sudo curl -kL dexterindustries.com/update_tools | sudo bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   243  100   243    0     0   3037      0 --:--:-- --:--:-- --:--:--  3075
100 37894  100 37894    0    bash: line 2: syntax error near unexpected token `newline'
 0bash: line 2: `<!DOCTYPE html>'
   229k      0 --:--:-- --:--:-- --:--:--  229k

copy pasted https://raw.githubusercontent.com/DexterInd/script_tools/master/install_script_tools.sh to local file

$ chmod a+x install_script_tools.sh 
$ ./install_script_tools.sh 
fatal: unable to access 'https://github.com/DexterInd/script_tools.git/': Failed to connect to github.com port 443: Connection refused
./install_script_tools.sh: line 62: cd: /home/pi/Dexter/lib/Dexter/script_tools: No such file or directory
fatal: not a git repository (or any of the parent directories): .git

I copied manually the install script repo, but now if I try to run my simple script again:

$ ./test_01.py 
from: can't read /var/mail/easygopigo3
./test_01.py: line 2: syntax error near unexpected token `('
./test_01.py: line 2: `gpg = EasyGoPiGo3() # instantiating a EasyGoPiGo3 object'

Here’s the log.txt from the robot, I got it via VNC:

GoPiGo3 Troubleshooting Script log

Checking for hardware, and checking hardware and firmware version.

Manufacturer : Dexter Industries
Board : GoPiGo3
Serial Number : 95758CA9514E4C47324B2020FF040222
Hardware version: 3.x.x
Firmware version: 1.0.0
Battery voltage : 8.943
5v voltage : 5.171

HELP !!!

Thank you in advance.

1 Like

What hardware and software are you using?

  • Pi version?
  • Software version and name?

Also, I noticed that the battery voltage is way low.  it should be above 10.5 volts otherwise the robot won’t function.

Though it’s probably not part of the problem you are experiencing now, you really want to get your battery voltage up to 12v.

This will help a lot.

Don’t worry, it’s probably a simple solution!

The log file was probably taken before replacing the batteries.

Can you please tell me how to get the Pi version (I don’t see it written on the board and don’t want to take the robot apart to check it, if possible) and software version & name ?

I flashed the SD card so many times, I can’t remember what it was last time.

1 Like

sudo uname -a will get you the operating system info.

I forget how to check the board version.

I tried to take a couple of pics to see what’s written on the board, and unless I’m blind, it says:
Raspberry Pi 3 Model B v1.2
Raspberry Pi 2015

$ sudo uname -a
Linux GoPiGo 5.10.63-v7+ #1496 SMP Wed Dec 1 15:58:11 GMT 2021 armv7l GNU/Linux

Here are the pics:

1 Like

I could only attach one pic, so here’s the 2nd:

1 Like

That’s a Pi-2.

Though (theoretically) it should work, it will be woefully under powered.

The minimum suggested version is a Pi-3B, that’s the minimum version things have been tested on, (work is also being done using the Pi-4 and Pi-5), and that version is known working.

Also, what version of the GoPiGo do you have?  Is it the red board version?


If it’s the red board version, go to GoPiGo.io and download the latest GoPiGo O/S, flash it to SD, try it and report results.

Boot it with a monitor and keyboard attached and look for boot errors.

If not, you will need to download Raspbian for Robots from the same source and try that.

These both come pre-cofigured and should work out-of-the-box.

Let us know what happens.

I’m pretty sure it’s a Raspberry Pi 3. Check both pics, in one of them the 3 is pretty clearly visible.
Raspberry Pi 3 Model B v1.2

The Dexter board is the red one (GoPiGo 3).

1 Like

My bad.

The picture resolution on my telephone stinks when zooming in. :man_facepalming:

Try the GoPiGo O/S and tell us what happens.  Use something like Etcher that verifies the integrity of the flash process.

Also, make sure you’re using good quality SD cards. Cheapo no-name cards, (this includes PNY and Kingston[1] [2], IMHO), generally don’t work well on Raspberry Pi’s version 3 or greater.  Micro Center cards on the other hand work well as they usually identify as a sub-brand of Toshiba.  Toshiba, SanDisk, and Samsung cards are usually good.

Try to find “application rated” cards, A1 or A2.  (A1 is sufficient.)

Note that out-of-the-box it is in “stand alone access point mode” broadcasting a WiFi network connection at

Also note that the first boot of the newly flashed SD card will take a few minutes since there is some filesystem and partition fixups it needs to do.  Go get a cuppa’ coffee (or tea) while you wait.

You can use the Ethernet port for internet connectivity, or flip it to “networked mode”.

I would suggest trying it out in access point mode first, then flip it to networked mode.

With this O/S, you don’t have to download anything, as it’s ready to go when you power it up.


  1. Ghost-shift manufacturing of Kingston branded SD cards:

  2. A web search for “ghost shift manufacturing” turns up a lot of interesting stuff.

Flashed a Toshiba SD card with GoPiGo OS Version 3.0.3 (from GoPiGo OS v 3.0.3 · GoPiGo.io).

Set up the WiFi.

Recreated the script and this time it worked.

I repeated the same steps I did a bunch of times before, but this time it worked. I don’t understand it, but it doesn’t matter !!!


1 Like

It’s easy.

You are running a supported, fully configured operating system with all its ducks in a row instead of a depreciated operating system from days gone by.

If you’re going to compete in a top-fuel drag race using a beat up Volkswagen, you should expect to get left behind.  Now that you have the tools to compete, you’re in business!

So, try something and share what you’ve done.  We’re all rooting for you!