I2cdetect not showing anything


#1

Hi there,

We are trying to connect grove pi to a raspberry pi 1b+.

We are following the software setting up guide,
http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/

and successfully connected the grove pi.

The lights on grovepi were on, but i2cdetect does not show anything, neither does any sensor work!

We tried everything on the forum, but nothing works. We need your help!

Thanks,

Quanyang


#2

Hi Quanyang,
Can you run the troubleshooting script by following the instructions here and upload the log to the forums so that we can narrow down the problem: https://www.youtube.com/watch?v=ZMadpIEYq5o&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=4.

-Karan


#3

Hi Karan,

The problem is exactly when I run

sudo i2cdetect -y 1

The guide said ‘If you can see a “04” in the output, this means the Raspberry Pi is able to detect the GrovePi.’

But we just did not get the “04”, they got all dashes. Thanks a lot!

QY


#4

Hey QY,
There are problems sometimes with the firmware and it is easy enough to correct. It would be great if you could run the troubleshooting script by following the instructions here and upload the log to the forums so that we can narrow down the problem: https://www.youtube.com/watch?v=ZMadpIEYq5o&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=4.

It would really help us out if you could upload the log here. We can then let you know what to do next.

-Karan


#5

Hi Karan,

We are trying to get access to troubleshooting application.

We don’t have a wifi module, so we tried to connect raspberry pi and my laptop with ethernet cable.

But nothing seem to happen when I typed “http://dex.local”, and then hit enter.

I want to know how to run the troubleshooting without the wifi module.

Also, we tried to log into the “http://dex.local” with connected ethernet by raspberry itself, and it also showed unresolved address.

Thanks,

QY


#6

Hey qlv,
It looks like you don’t have access to the SSH on the Raspberry Pi yet, so were you running the I2C detect command on your own computer rather than the raspberry pi. Are you using windows or Mac. If you are using windows, have you installed the Bonjour from here: https://support.apple.com/downloads/Bonjour_for_Windows. Also, what image are you using with the Raspberry pi.

-Karan


#7

Hi Karan,

We were running the command on raspberry pi.

And we are using windows currently, so just simply install Bonjour and try again?

Will it work since we only have the ethernet cable?

Qy


#8

I am not sure about the image. I am using the original noobs system on the raspberry pi.

QY


#9

Hey QY,
dex.local only works with the Raspbian for Robots image from Dexter Industries. It also comes loaded with all the software and packages so that you are ready to run them.

You can download and install the image from the directions given here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/ or you can directly buy an SD card loaded with our image from here: http://www.dexterindustries.com/shop/sd-card-raspbian-wheezy-image-for-raspberry-pi/.

One the SD card has the Raspbian for Robots image, then you should be able to use the dex.local for logging in.

-Karan


#10

Hi Karan,

We newly found that both lights, power and reset, are always on when the board is on, which may suggest it is always trapped in reset mode.

Do you how to solve that?

Thanks,

QY


#11

Hey QY,
If you have SSH access to the Pi, you should definitely run this: https://www.youtube.com/watch?v=ZMadpIEYq5o&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=4 and upload the log here. We can easily look at the state of the GrovePi and what has to be done to make it work again by looking at the log. It might be something as simple as resetting the GrovePi from the software, or might require a firmware update.

-Karan


#12

Hi Karan,

This is our troubleshooting log. Thanks a lot!

QY


#13

Hey QY,
It looks like the firmware on the chip is not working properly or might have been erased accidentally. Can you follow the guide here to install the firmware: https://www.youtube.com/watch?v=VUVvU4YcTvo. This should solve the problem.

-Karan


#14

Hi Karan,

I’m a member in Quanyang’s project. I tried to follow the guide on the Youtube. However, we are still unable to connect to http://dex.local. Last time you asked us what image we are using. So the system we are using is the system recommended by the official guide (https://www.raspberrypi.org/help/noobs-setup/). We downloaded and installed the system by ourselves. Today we also tried downloading the image you recommended(http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/). But after we completed all the installation steps and tried to run the new SD card, there was no signal sent to the monitor. We have checked that the monitor works well if we use the old system. But for the new system, it doesn’t work. Could you please check if the newest image is correct? And is there any other simple way to check? Currently we are directly using raspberry pi as we don’t know if we can connect Grove Pi to our own laptop and how to do that.

Thank you,

Yusheng


#15

Yusheng, regarding the image: did you check the MD5 hash before installing?


#16

Yes, I have checked the MD5 hash and it was the same as the one shown on the website. It’s the newest one released on 2016.03.20.


#17

Hey yushengz,
When you enter the SD card into the computer, what drive is mounted. Can you attach a screenshot of what you see there. Also, what happens to the LED’s on the Raspberry Pi when you put the SD card on it and power on the Raspbbery Pi. Can you attach a picture of your raspberry pi setup connected to the monitor.
-Karan


#18

I’ve also been facing a similar problem. The grovepi+ module operates perfectly when I use a raspbian wheezy installed sd card. However when I tried another sd card with jessie lite both the reset and pwr leds stayed on and there was no 04 in the “sudo i2cdetect -y 1” output. When I tried to update the firmware there was an error message saying “avrdude: Can’t find programmer id gpio”. I also noticed that every time I ran install.sh, the pi uninstalled python-rpi.gpio and then reinstalled it. Besides this there was no abnormal response.

But, as I said earlier, the system runs perfectly if I switch the sd card back to wheezy. I wanted to upgrade the os as I use other apps on the pi and have been trying to integrate sensor inputs from grove.

Is jessie lite not supported yet or can I use the full blown jessie?

Thanks.


#19

Hey s.roy,
We are still working on getting our image and software to work on Jessie. Rigtn now running the software and install scripts on Jessie is not supported. We haven’t seen a lot of programs which don;t work on Jessie and you should be able to use most of them with our latest Raspbian for robots image. Can you tell us about the software which you are trying to use with Jessie.

-Karan


#20

Thanks for the response.

I’m not doing anything specific and I’m not an expert either. Just googling the net for apps and testing out their functionality. Basically I’m still trying to learn to capture sensor data and use it productively. This reminds me to ask is there any way to map gpio pins to grove sensors? How can I transfer data from grove sensor to a shell script which expects data from a particular gpio pin? An example will be much appreciated.

Also, do let me know if you need any sort of assistance. I don’t know if I’ll be able to do much but I’ll surely try my best to help :slight_smile: