Initial Setup


#1

I just got my GoPiGo kit, and it is all physically put together. I now have a monitor and keyboard hooked up to the PI, so I can setup the wifi and test it out. I’ll use ssh in the future to access it. When I boot it up, though, I just get prompted for a login, but the standard pi/raspberry login doesn’t work.

(none) login:
“Unable to determine your tty name”

Am I supposed to do anything with the gopigo sd card prior to putting it in the PI?

Thank you,
-Jason


#2

I don’t know why this happens, but you could always try re-formatting the SD card and starting afresh with a GoPiGo or NOOBS (or other) image. I got mine set up using NOOBS 1.3.10, connected it to the Internet and then got the GoPiGo stuff using “git clone …” If anything doesn’t work that way you could ask for help on the Raspberry Pi forums.


#3

Hi Jason,
The default username should be “pi” and the password “raspberry”. We haven’t faced this issue before. If this does not work, try reflashing the card and let us know if this works.

-Karan


#4

Thanks for the suggestions everyone. I tried the username pi, but it then immediately says “Unable to determine your tty name” and does not let me attempt to put in a username. I’ve worked with many PIs before, and never saw something this before.

I guess I’ll try reflashing the sd card later today and see if that works. Thanks.


#5

Any help on how to reflash the micro sd card?

The sd card, when plugged into a Windows computer, says it needs to be reformatted and that it will only be 56MB once formatted using FAT. I cancelled that. When plugged into a Mac, I can see the files on the card, but I can’t find a tool for the mac to write the image to the card. The gopigo instructions just say to use the windows tool win32diskimager.

Thanks,
-Jason


#6

Hey Jason, sorry that didn’t work.

Disclaimer: we haven’t done this with a mac before.

Here’s the Pi website’s official documentation on getting an image on an SD card: http://www.raspberrypi.org/documentation/installation/installing-images/mac.md


#7

I’m happy to use Windows. Is it normal to have to reformat the sd card, though? And with your 4gb card, what should the size be after reformatting?

Thanks,
-Jason


#8

I think the SD card we shipped should come to 3.8 or 3.9 GB after it’s reformatted.

We should backup: are you using our image that you bought from us? Or did you download our image and install it on an SD card you had?


#9

I have a 4gb card that came from you guys with the gopigo kit. As soon as I plug it into my Windows computer, Windows says it needs to be reformatted (can’t see anything on the card).

If I plug it into a Mac, I see about a dozen files, and the card’s name is boot.

Thanks,
-Jason


#10

Hi Jason,
It’s ok if the Windows prompts you to format the drive, don’t format it though. A 55MB drive should appear in the Windows Explorer which has a few files. Try booting with this SD card now and if still does not work try burning a new image on the SD card from the link mentioned above.

-Karan


#11

HI all,

Got my son got a GoPiGo for xmas.
We encountered the same error upon boot. “Unable to determine your tty name”

After trying everything my brother in law and I could think of, we re-imaged the SD card with the Dexter Industries build (not sure the terminology). This resolved the issue.

Dexter Industries - FYI the SD card was purchased from your pre-imaged, it is labelled RASPBIAN FOR ROBOTS 2014.07.30 perhaps there is a dodgy batch.

I’ve only got as far as running the basic_test_all.py. But this test was successful.

Regards Kevin


#12

Thanks everyone. I’m trying to use win32diskimager, but it fails because it says there isn’t enough space on the sd card to write the image. I’ve tried every partition/format tool I have on Mac and Windows and I can’t get more than one ~56MB partition on the sd card.

Is there anything I can do other than just go out and buy a new micro sd card?

Thanks,
-Jason


#13

Hey Jason,
Can you try out the v.1 of the Win32Disk Image from here: http://code.google.com/p/learn-gdx/downloads/detail?name=win32diskimager-RELEASE-0.1-r15-win32.zip&can=2&q= .

This one does not check for the size of the SD cards before writing the image.

Do let us know if this helps.

-Karan


#14

Jason, to reformat and resize the SD card, you can use this tool: https://www.sdcard.org/downloads/formatter_4/

Be sure to select the right drive! Also be sure to click “Options” and make sure you’re resizing your image. When you finish you should have a blank 3.9GB SD card you can use Win32 Karan refers to on.


#15

It looks like the newer version of win32diskimager is working. I’ll try the sd card formatter if the disk imager doesn’t work for some reason. Thanks everyone. I’ll let you all know how it goes.


#16

It works! That newer version of diskimager worked great, and now the PI boots up just fine. Thanks again everyone!


#17

Great news! Glad it worked!