Install Observations


#1

Hi - I thought i would document a few things i learnt while building and running the gopigo. Hope it helps others - these might be obvious to some, but were not to me or my son.

  • put the motor nuts and bolts in the other way around - ie nuts on the inside. It makes it easier to put the second motors bolt in and also i found that the bolt was too long and rubbed on the wheel.

  • dont over tighten the nuts and bolts on the motor - i broke a plastic piece (thanks for providing spares!)

  • the internal tracking wheel is VERY loose, but a bit of “bluetac” (putty for hanging pictures) worked perfectly to hold them on.

  • the motors wiring needs to be opposite to each other or one wheel goes forward and one backward. ie just switch the connections around if you have this problem - white wire on motor 1 to + and the other motors white wire to - .

  • it was not obvious to me as to how to connect the servo. I have attached an image of what i did - it works but there may be a simpler way.

  • the sample script on the web site should read ‘“d” to move right’ - there are currently 2 lefts and no right. The program is correct.

  • the scratch start script has the wrong permissions. “rw-r–r-- ir” needs “rwxr-xr-x”. A chmod of 755 is needed. So does the other script “chmod 755 GoPiGo*.sh”

This is such a great project, i am so looking forward to learning pi, python, unix.

Clive


#2

First I want to say GREAT JOB. Everything is up and working and me and my son had a blast working on it.

Just want to second all these comments. I encountered all of the same issues, with the exception that I haven’t tried the scratch connection yet. Will give the blue tac a try on the inner wheels.

Also of note, the rasbian image you provided looks like it’s all set up for the brick pi, but has nothing on it with regard to the gopigo right now. I followed the directions for grabing the git repo and using this for doing the installation. That worked.


#3

I had to run the “python gopigo.py install”, from the correct directory of course.

All the gopigo code is on my image as are the icons on the desktop.

under user/pi i had a GoPiGo directory and under that Hardware, Firmware, Software (Scratch and Python), etc - with everything in it - including the firmware 1.0 and 1.1.

Great to see the GoPiGo.py and the Firmware 1.1 .ino code to see how they communicate.

You have really provided a complete package.


#4

Thanks everyone for the great feedback.

We have made a note of the hiccups that you had faced with the assembly and software setup and will update that in the documentation.

Thanks,
-Karan


#5

Hey folks,
thanks so much for the feedback. We’re going to be working on a set of improved assembly instructions tomorrow, and hopefully have them up by the end of the week. These comments are really, really appreciated. Thank you so much, we’ll report back with a link as soon as I have something up.

Thanks again!


#6

Can you make an short how-to for the servo + camera?


#7

I’m playing it safe and waiting for the updated assembly instructions before I hook up the motors, but I have completed the assembly otherwise. Here’s a minor addition to what’s already been reported: the posts intended to hold the battery pack in place are too short; the battery pack (even without batteries in it) doesn’t fit as shown in the assembly video [maybe it’s the battery pack?]


#8

Hey folks, just a quick update: General assembly instructions are now up here: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/1-assemble-the-gopigo/

For those that have already gotten their robots up and running, please comment and let us know if we missed something!

I am starting on a written tutorial for the servo, and then the camera and Ultrasonic. I’ll report back.

@Clive, I think I’ve hit all your points. Thank you again for the advice!


#9

Servo package instructions here: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/1-assemble-the-gopigo/assemble-servo-package-assemble-the-raspberry-pi-robot-servo-kit-with-the-gopigo/


#10

And finally, how to attach the camera and ultrasonic sensor. http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/1-assemble-the-gopigo/attaching-a-camera-or-ultrasonic-sensor-raspberry-pi-robot-kit/


#11

That all looks great. I would just add in the scratch programming page that they may need to change the permissions on the 2 startup scripts - unless your have done this in the upgrade scripts? (startup calls debug script)

Happy to help - i have lots of plans to try with my GoPiGo - hope to post some pics (and vids) when its working.

Clive


#12

I finally have it up and running now also. I had troubles with the wireless config. I changed the “manual” at the end to dhcp and added “auto wlan0”.

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface wlan0 inet dhcp
… followed by ssid / psk

I used a USB powerbank to test drive it :slight_smile:

Anyway great project!

PS - with the battery pack it’s much faster than with the powerbank :wink:


#13

Hi,
I thought I’d include some issues I had in case anyone else runs into them. I was starting with the SD image from DexterIndustries from 6-13 because I was unable to unzip the version from 7-30 on my mac - I get into an infinite loop trying to unzip this, 6-13 works fine. As this version didn’t have the GoPiGo files I cloned them from GitHub. First off it wasn’t clear that these should be copies to the Desktop (if you don’t then it can’t find some of the scripts since the path is hardcoded). I ran the install script, however in that script it tries to copy the gpg script to /usr/bin. In my distribution, there is the pgp encryption file called gpg already there. I had to remove that in order to get all of the scripts working so I could update the firmware. All is working now!

Hope this is helpful.

Thanks,
Shari


#14

Hi Shari,
Thanks for your inputs with the install process.

We haven’t seen anyone else having a problem with the SD card image. We will look into it if we hear anyone else also facing the same problem.

Right now the path is hardcoded because it is much more easier for simple folks to get the GoPiGo up and running. Maybe we’ll make it more dynamic in the future.

The “gpg” file which is copied to /usr/bin allows you to check the GoPiGo’s voltage and firmware using the “gpg” command on the terminal. You can rename it to anything else and use that to check the voltage and the firmware version.

Thanks again,
Karan