IR receiver doesn't work?


#1

Hello
I would like to test a IR receiver (model RB-See-185) with my GrovePi but I don’t know if I do the correct actions.
I connect the sensor on a A0 port and launch the script: /Desktop/GrovePi/Software/Python/grove_ir_receiver.py (with parameter in script pin port=1).
Nothing is not happening when I test with my remote controler.

I have tested:

  • an other analogic port
  • a numeric port
    but nothing.

Could you help me? I’m newbie in Raspberry/GrovePi world :slight_smile:

Attached my configuration.
All update are done on software and firmware.


Grove IR Receiver not working with RasPi3 B and GrovePi+
#2

Hey,
The IR receiver can only be used with the serial port. Can you try out the instructions and example here: https://github.com/DexterInd/GrovePi/tree/master/Software/Python/grove_ir_receiver.

-Karan


#3

Hello
I have launched the script with the ir receiver on serial port. Attached script logs.
Nothing appears on screen :frowning:

Thank you.


#4

Hey,
If it has been set up correctly, you’ll have to follow the instructions here: http://alexba.in/blog/2013/01/06/setting-up-lirc-on-the-raspberrypi/ to set up the Pi to work with your receiver. The big change here would be that you have to use lirc_rpi gpio_in_pin=14 everywhere in that page instead of gpio_in_pin=23,gpio_out_pin=22.

-Karan


Grove IR Receiver not working with RasPi3 B and GrovePi+
#5

Hello
My steps after your answer:

  • sudo apt-get install lirc : already installed
  • /etc/modules : there are 2 lines with “lirc_rpi gpio_in_pin”
  • /boot/config.txt : there are 3 lines with “dtoverlay=”
  • I have tested with command “mode2 -d /dev/lirc0” : nothing appears on screen
  • modify /etc/modules : comment line with port 15
  • modify /boot/config.txt : comment lines “dtoverlay=” other with 14
  • reboot
  • I have tested with command “mode2 -d /dev/lirc0” : nothing appears on screen ;-{

Attached my logs + photo.

Thank you.


#6

Hey,
Can you connect the sensor to the first port RPISER instead of the second port. Also, first try out dtoverlay=lirc-rpi,gpio_in_pin=14. If this doesn’t work then try out dtoverlay=lirc-rpi,gpio_in_pin=15.

-Karan


#7

Hello,
My tests:

  • IR receiver connected on port serial (at left at the first test first port)
  • boot with /boot/config.txt : dtoverlay=lirc-rpi,gpio_in_pin=14
  • check with command mode2 -d /dev/lirc0 : nothing
  • modify /boot/config.txt : dtoverlay=lirc-rpi,gpio_in_pin=15
  • check with command mode2 -d /dev/lirc0 : nothing
  • reboot
  • check with command mode2 -d /dev/lirc0 : nothing

Test with an other remote controler : nothing.

Thank you for your patience :slight_smile:


#8

Not really sure why this is not working for you. We have used the same tutorial here to set up the IR receiver: http://alexba.in/blog/2013/01/06/setting-up-lirc-on-the-raspberrypi/. Would it be possible for you to use jumper wires to directly connect the IR receiver to the GPIO pins on the Raspberry Pi, and maybe start with a fresh noobs image to see if it works.

-Karan


#9

Hello
I have followed yours instructions:

  • reinstall with Noobs image
  • install lirc package
  • directly connect IR receiver on GPIO (RX on n°23)
  • modify /boot/config.txt:
    # Uncomment this to enable the lirc-rpi module
    dtoverlay=lirc-rpi

Uncomment this to override the defaults for the lirc-rpi module

dtparam=gpio_out_pin=16
dtparam=gpio_in_pin=23
dtparam=gpio_in_pull=down

  • sudo /etc/init.d/lirc stop
  • mode2 -d /dev/lirc0

and it works ! I see signal texts.

What do you think of the problem origin? My grovepi board has a problem?
Thank you.


#10

Hey ygrakes,
Great to hear that the receiver is working for you. Are you using the Grove IR receiver or something else. How are you connecting the sensor to the Raspberry Pi right now and can you add a picture of the IR receiver and the connections. Also, why do you have dtparam=gpio_out_pin=16 and isn;t there another line like dtoverlay=lirc-rpi,gpio_in_pin=15 to associate the pin with LIRC. I think the GrovePi is fine, there might be some small problems with the connections or the configurations.

-Karan


#11

Hello
My answers :

but the IN PIN wasn’t correct. I have tried with 23 port number and it worked.

Thank you :slight_smile:


#12

Hi ygrakes,
Great to hear that the IR receiver is working for you. I did have a look at the link that you had mentioned above and it does look like you are directly connecting the IR receiver to the GPIO pins. The GrovePi has a RPISER port which is directly connected to the Serial GPIO’s on the Pi and should allow you to directly use the sensor without using jumpers if you want to switch to using that. The only other big difference that I found was the dtparam=gpio_in_pull=down parameter. We have not been using this too.

Great to hear that it worked for you. Do let us know more about the project that you are building with it.

-Karan