Ir_receiver module not working


#1

hi
I just bougth a grovepi
plug it onto my raspberry 2 (os raspbian wheezy)
install grovepi software and new firmware fron 255.255.255 to 1.2.2
update grovepi software
run Desktop/GrovePi/Software/Python/grove_ir_receiver/script/ir_install shell script
plug the ir_receiver module
stop lirc daemon and run « mode2 -d /dev/lirc0« command
press some key of my tv remote control (sony)
nothing happen !
What’s wrong ?

thanks


#2

Hello p.selles

There are a couple of things that might be going wrong. The most obvious one being that the tv remote is not compatible. You need to use the KEYES remote or reprogram the IR sensor to use another remote. The default setup is for the KEYES>

Should you wish to reconfigure the IR sensor, this is how I did it (I happen to have a non compatible KEYES knock-off)

sudo /etc/init.d/lirc stop
irrecord -d /dev/lirc0 ~/my_lircd.conf
sudo mv /etc/lirc/lircd.conf /etc/lirc/lircd_backup.conf
sudo cp ~/my_lircd.conf /etc/lirc/lircd.conf
sudo /etc/init.d/lirc start

When running irrecord, you will be asked to supply button names. You can get the list of ‘legal’ button names by running
irrecord --list-namespace first.

I hope this helps. Let me know if you’re still having issues.

Cleo


#3

thanks

not sure but i think that mode2 -d /dev/lirc0 command dont use /etc/lirc/lircd.conf.

do you know the gpio pins used by grovepi rpi serial port?


#4

mode2 -d /dev/lirc0 should give out the codes if the sensor is receiving anything from the remote. The RPISER port is connected to the Serial pins on the Raspberrry PI which are BCM 14 and BCM 15 pins (https://pinout.xyz/pinout/pin2_5v_power), the ones marked in purple.

One of the things to be careful about is the version of the IR receiver. There are modules which use TX pins and some which use RX pins. This is a good guide to follow to get the IR receiver working: http://alexba.in/blog/2013/01/06/setting-up-lirc-on-the-raspberrypi/ . There are config files, /etc/modules and /boot/config.txt which need to have a parameter called gpio_in_pin=<pin_number> which has to be 14 or 15 for the GrovePi. Here is a script which usually does it for the module : https://github.com/DexterInd/GoPiGo/blob/master/Software/Python/ir_remote_control/script/ir_install_manually.sh. You might be able to take some pointers from this. It might be worth trying out the setting with 14 and 15 one by one and see if that works.

Do let us know if this helps