Is my GrovePi Dead or faulty

Hi I’ve had a GrovePi for about 2 years, and seems not to work any more, example is it can not tell me what firmware is loaded, when is run. The script stalls at that point.

Have you any suggestion, has it become useless?

Log below

Check space left

Filesystem Size Used Avail Use% Mounted on
/dev/root 29G 3.7G 24G 14% /
devtmpfs 430M 0 430M 0% /dev
tmpfs 462M 0 462M 0% /dev/shm
tmpfs 462M 7.3M 455M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 462M 0 462M 0% /sys/fs/cgroup
tmpfs 6.0M 0 6.0M 0% /home/pi/WxRam
tmpfs 4.0M 0 4.0M 0% /home/pi/Logs
tmpfs 4.0M 480K 3.6M 12% /var/log
tmpfs 2.0M 0 2.0M 0% /home/pi/Archive
tmpfs 2.0M 0 2.0M 0% /var/log/nginx
/dev/mmcblk0p1 253M 49M 205M 20% /boot
tmpfs 93M 4.0K 93M 1% /run/user/1000

Check for dependencies

python 2.7.16-1 install ok installed
python-pip 18.1-5+rpt1 install ok installed
git 1:2.20.1-2+deb10u3 install ok installed
libi2c-dev 4.1-1 install ok installed
python-serial 3.4-4 install ok installed
python-rpi.gpio 0.7.0-0.1~bpo10+4 install ok installed
i2c-tools 4.1-1 install ok installed
python-smbus 4.1-1 install ok installed
scratch install ok installed

I2C still in blacklist
SPI still in blacklist

Check for addition in /modules

I2C-dev already there
i2c-bcm2708 already there
spi-dev already there

Hardware revision

RPI3 Pi 3 Model B v1.2

Check the /dev folder


USB device status

Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
|__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
Raspbian for Robots Version

cat: /home/pi/di_update/Raspbian_For_Robots/Version: No such file or directory



Checking for Atmega chip

avrdude: Version 5.10, compiled on Jun 18 2012 at 12:38:29
Copyright (c) 2000-2005 Brian Dean,
Copyright (c) 2007-2009 Joerg Wunsch

     System wide configuration file is "/etc/avrdude.conf"
     User configuration file is "/root/.avrduderc"
     User configuration file does not exist or is not a regular file, skipping

     Using Port                    : unknown
     Using Programmer              : gpio

gpio/direction: No such file or directory

avrdude done. Thank you.

Checking I2C bus for devices

Checking I2C bus 0

NOTE: it is normal for this one to fail
Error: Could not open file /dev/i2c-0' or /dev/i2c/0’: No such file or directory

Checking I2C bus 1

 0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f

00: – 04 – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –

Checking for firmware version

Thanks Michael

1 Like

I don’t know if this means anything, but this would be what I would look at first, because (AFAIK) being β€œblacklisted” means these two essential services won’t run.

Are i2c and SPI turned on in raspi-config? If not, they won’t work.

What version of Raspbian For Robots are you running?

Other things you can try after resolving the blacklist issue:

  • Are you running as the β€œpi” user? Much if the Dexter Industries software assumes that you are running as β€œpi” and won’t work as any other user.

  • Have you tried the β€œDexter Update”? (There should be an icon on the desktop for it.)

  • Have you tried re-flashing your OS image? Bit-rot can happen, especially on older, unused images.

Let us know what happens! :wink:

1 Like

Since I have a couple of Grovepi’s I swapped them around and placed it on a raspberry pi3 which had a working grovepi on it, it still did not work, the other one work ok on the other Raspberrypi3

Any Thoughts

1 Like

send the log from the test and particulars to

1 Like


I run all my software using sudo, as some will not run, I have run a full update, and am using the latest raspberry pi OS image,n regarding the two black listed items, sure I2C and SPI would not work, if they turned off.

I have run on my all my raspberry pi with a GrovePi, and they all show I2C still in blacklist, SPI still in blacklist.

The faulty Grovepi is able to access the firmware version, and the programme stall at that point

Checking for firmware version

Other than that I cannot see any differences, it looks like the problem may be with the firmware chip?

Should I regard that grovePi as dead, or is there fix?

Regards Michael

1 Like

Sounds like your firmware may be β€œblown”.

BTW, who manufactured the Grove Pi board? Dexter Industries or someone else like Seeed Studios?

Did you ever try to do anything with the firmware using a Pi-4? There is a known issue with trying to update firmware (on a GoPiGo-3) using a Pi-4.

If the problem is corrupt firmware, (instead of a fried board), you can TRY, (the important keyword here being β€œtry”), to get it working by doing by doing the following:

  • Download and use DexterOS on a Pi-3 or earlier. (I’ve used a Pi-3 to do this)

  • Connect the Pi-3 to the defective board, a screen, monitor, keyboard and mouse.

    • Use a generously rated supply. An β€œofficial” Raspberry Pi supply is a safe bet.
  • Start the system and get to the Dexter desktop.

  • Run the Dexter Update software - there’s an icon on the desktop and verify that the detected robot is β€œGrove Pi”.

  • Attempt to update the firmware.

(a) The firmware can actually be updated.


(b) If this works.


(c) You might end up with a good board.

Otherwise, you can take the defective board, cast it in a clear epoxy resin, and have a totally rad paperweight!

Is this, (updating firmware on a Grove Pi board), even doable?